Re: [PULL 00/56] Misc HW patches for 2026-08-16
Richard Henderson <[email protected]>
| Newsgroups | org.nongnu.qemu-devel |
|---|---|
| Message-ID | <[email protected]> |
On 8/16/26 07:44, Philippe Mathieu-Daudé wrote:
> The following changes since commit af06b5df2610fe5de6c02d17c17bced9e9f0d47d:
>
> Merge tag 'qom-qdev-20260814' ofhttps://gitlab.com/mcayland-ntx/qemu into staging (2026-08-14 08:44:51 -0700)
>
> are available in the Git repository at:
>
> https://github.com/philmd/qemu.git tags/hw-misc-20260816
>
> for you to fetch changes up to b409523587c49a08b1ddadd51212a320092347b1:
>
> hw/core/machine: Move EHCI migration compat properties to 11.1 (2026-08-16 16:35:27 +0200)
>
> ----------------------------------------------------------------
> Misc HW and Monitor patch queue
>
> - Bug fixes
>
> . Reinstate x86/pc 'xenfv' machine alias
> . Defend against malformed ELF headers to prevent underflows
> . Restore ROMD mode after migration for Intel PFlash (CFI01)
> . Fix VLAN tag handling on incoming packets on RTL8139 model
>
> - Refactoring (Monitor, common CPU, NMI)
>
> . Add missing inclusions and remove unnecessary ones
> . Use qdev_is_realized() consistently (no direct field access)
> . Remove deprecated DEFINE_PROP_DMAADDR() macro
> . Renaming churn around cpu_{exec,common}* helpers
> . Simplify NMI API hanlding
> . Move QMP handlers (physmem, nmi) to appropriate subsystems
> . Replace container_of() casts with HMP typed accessors
> . Rename @mon to @hmp in MonitorHMP for clarity
Applied, thanks. Please update https://wiki.qemu.org/ChangeLog/11.2 as appropriate.
r~