Re: [PATCH v2 3/3] migration/rdma: Retry control sends on full queue
Yanfei Xu <[email protected]>
| Newsgroups | org.nongnu.qemu-devel |
|---|---|
| Message-ID | <[email protected]> |
On 2026/8/21 22:25, Peter Xu wrote:
> On Fri, Aug 21, 2026 at 10:10:40AM -0400, Peter Xu wrote:
>>> + switch (wr_id) {
>>> + case RDMA_WRID_RDMA_WRITE:
>>> + wr_desc = "RDMA write";
>>> + break;
>>> + case RDMA_WRID_SEND_CONTROL:
>>> + wr_desc = "control send";
>>> + break;
>>> + default:
>>> + wr_desc = "send work request";
>>> + break;
>> Do we have other possibility? I thought it should be either WRITE or SEND,
>> if so, we could g_assert_not_reached().
> Some side discussion..
>
> Since we're talking about the wrids, IIUC the whole RDMA wrid space is a
> bit messy. E.g. RDMA_WRID_SEND_CONTROL is used without having
> RDMA_WRID_CONTROL (2000, rather than 2022) for SEND control messages.
>
> IIUC the two-layered wrid name space is confusing, maybe we can rewrite the
> wrid allocation to only use one namespace with very limited wrid
> possibilities, selecting rdma->wr_data[] index based on the few
> possibilities. My gut feeling is that's much easier to read.
I agree it would be better with using one namespace.
>
> In all cases, this will be a separate discussion, not relevant to this
> series alone, but I want to see if I'm the only one got confused by these
> two-layered RDMA_WRID_*.
It's true that the two-layered RDMA_WRID_* are not that clear, and I have to
rely on their comments to understand them.
Regards,
Yanfei
>
> Thanks,
>