Re: [PATCH v2 6/6] qom/object.c: rename object_class_property_uint*_ptr() to object_class_static_property_uint*_ptr()

Daniel P. Berrangé <[email protected]>
Newsgroups org.nongnu.qemu-riscv,org.nongnu.qemu-devel
Message-ID <[email protected]>
On Fri, Jul 17, 2026 at 02:51:46PM +0100, Mark Cave-Ayland wrote:
> This more accurately reflects that these properties are held within the class and
> not the object. Update the documentation to describe the few cases where static
> properties should be used.
> 
> Signed-off-by: Mark Cave-Ayland <[email protected]>
> ---
>  include/qom/object.h | 56 +++++++++++++++++++++++++++++++-------------
>  hw/riscv/spike.c     |  5 ++--
>  qom/object.c         | 28 ++++++++++++----------
>  3 files changed, 59 insertions(+), 30 deletions(-)

Reviewed-by: Daniel P. Berrangé <[email protected]>


With regards,
Daniel
-- 
|: https://berrange.com       ~~        https://hachyderm.io/@berrange :|
|: https://libvirt.org          ~~          https://entangle-photo.org :|
|: https://pixelfed.art/berrange   ~~    https://fstop138.berrange.com :|
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.