Re: [PATCH 04/12] hw/arm/virt: prefix ACPI helpers with arm_virt_
Philippe Mathieu-Daudé <[email protected]>
| Newsgroups | org.nongnu.qemu-riscv,org.nongnu.qemu-arm,org.nongnu.qemu-devel |
|---|---|
| Message-ID | <[email protected]> |
On 23/8/26 17:07, Yonggang Luo wrote: > - virt_acpi_setup and virt_is_acpi_enabled are generic names also used > by RISC-V and LoongArch virt. A combined binary cannot export two > functions with the same C symbol. > - Rename the ARM helpers to arm_virt_acpi_setup and > arm_virt_is_acpi_enabled. Leave the trace event virt_acpi_setup > unchanged; it is a separate identifier. > > Signed-off-by: Yonggang Luo <[email protected]> > --- > hw/arm/virt-acpi-build.c | 4 ++-- > hw/arm/virt.c | 12 ++++++------ > include/hw/arm/virt.h | 4 ++-- > 3 files changed, 10 insertions(+), 10 deletions(-) Reviewed-by: Philippe Mathieu-Daudé <[email protected]>