Re: [PATCH batadv-next 2/2] batman-adv: tt: replace open-coded overflow check with helper
Antonio Quartulli <[email protected]>
| Newsgroups | org.open-mesh.lists.batman |
|---|---|
| Message-ID | <[email protected]> |
On 03/05/2026 22:46, Sven Eckelmann wrote:
> The commit 6043a632dd06 ("batman-adv: reject oversized global TT response
> buffers") introduced an open-coded check to ensure that the allocated
> buffer size can be stored in a u16. The check_add_overflow() helper can
> perform the addition and overflow check in one step, so use that instead.
>
> Signed-off-by: Sven Eckelmann <[email protected]>
Acked-by: Antonio Quartulli <[email protected]>
--
Antonio Quartulli