Re: [PATCH net v2] batman-adv: reject unrepresentable multicast TVLV offsets
Jakub Kicinski <[email protected]>
| Newsgroups | org.open-mesh.lists.batman,org.kernel.vger.linux-kernel,org.kernel.vger.netdev,org.kernel.vger.stable |
|---|---|
| Message-ID | <[email protected]> |
On Mon, 10 Aug 2026 14:57:51 +0000 David Lee wrote: > + long transport_offset = skb->data - skb->head + offset; > + > + if (unlikely(transport_offset != > + (typeof(skb->transport_header))transport_offset)) > + return false; > + > + if (unlikely(transport_offset == > + (typeof(skb->transport_header))~0U)) > + return false; > + > + skb->transport_header = transport_offset; > + return true; Find a better name for the variable instead of wrapping the lines.