RE: [bitbake-devel] [PATCH 0/3] Remove bb.fetch compatibility shim module
| Newsgroups | org.openembedded.lists.bitbake-devel |
|---|---|
| Message-ID | <DM8PR12MB54303D8EC454EA621D9171028BA32@DM8PR12MB5430.namprd12.prod.outlook.com> |
Hi Alex, > On Fri, 21 Aug 2026 at 19:06, Chris Laplante via lists.openembedded.org > <[email protected]> wrote: > > fetch2 replaced fetch a long time ago (2012) so I argue it is time to > > say goodbye the bb.fetch shim. > > Why not instead rename fetch2 to fetch and drop the unneeded '2'? Is there a > reason to keep the number? I thought about it, but I'd bet 'fetch2' is more prevalent than 'fetch' in third-party layers. We also document the naming choice: https://docs.yoctoproject.org/bitbake/bitbake-user-manual/bitbake-user-manual-fetching.html#file-download-support. So I think it would result in breaking a bunch of layers. Whereas if people are still using bb.fetch, we can point to the manual if they complain. That being said, I'm not opposed to going the 'fetch' route if people prefer it. Thanks, Chris