[PATCH] bus: fsl-mc: drop unused assignment of acpi_device_id::driver_data
"Pawel Zalewski (The Capable Hub)" <[email protected]> Tue, 28 Jul 2026 11:58:56 +0100
| Newsgroups | org.ozlabs.lists.linuxppc-dev,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
This module sets the acpi_device_id::driver_data to 0 but the field is not actually used within the module, we can just drop it from the table. While we are at it - use a named initializer for the acpi_device_id::id field as well to make the code more readable. Signed-off-by: Pawel Zalewski (The Capable Hub) <[email protected]> --- drivers/bus/fsl-mc/fsl-mc-bus.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/bus/fsl-mc/fsl-mc-bus.c b/drivers/bus/fsl-mc/fsl-mc-bus.c index 64d75eed0d34..ce024a0fb7e4 100644 --- a/drivers/bus/fsl-mc/fsl-mc-bus.c +++ b/drivers/bus/fsl-mc/fsl-mc-bus.c @@ -1202,7 +1202,7 @@ static const struct of_device_id fsl_mc_bus_match_table[] = { MODULE_DEVICE_TABLE(of, fsl_mc_bus_match_table); static const struct acpi_device_id fsl_mc_bus_acpi_match_table[] = { - {"NXP0008", 0 }, + { .id = "NXP0008" }, { } }; MODULE_DEVICE_TABLE(acpi, fsl_mc_bus_acpi_match_table); --- base-commit: 62cc90241548d5570ee68e01aaba6506964e9811 change-id: 20260728-acpi-bus-ad68cd1f6d1d Best regards, -- Pawel Zalewski (The Capable Hub) <[email protected]>