Re: [PATCH v2 1/2] powerpc/rtasd: Use struct_size() to simplify log_rtas_len()
Madhavan Srinivasan <[email protected]> Mon, 3 Aug 2026 12:27:55 +0530
| Newsgroups | org.ozlabs.lists.linuxppc-dev,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
On Sat, 27 Jun 2026 12:47:30 +0200, Thorsten Blum wrote:
> Now that struct rtas_error_log uses a flexible array member for the
> extended log buffer, use struct_size() to calculate the total RTAS error
> log size and avoid using the hard-coded header size of 8 bytes.
>
> Use min() to replace the open-coded implementation while at it.
>
>
> [...]
Applied to powerpc/next.
[1/2] powerpc/rtasd: Use struct_size() to simplify log_rtas_len()
https://git.kernel.org/powerpc/c/6a7f74525a9964ef3228f6e1d1af261e92964987
[2/2] powerpc/pseries/ras: Use struct_size() to simplify fwnmi_get_errinfo()
https://git.kernel.org/powerpc/c/351496d6aea664f25cbd6411bf5567210328e419
cheers