RE: [5/7] soc: aspeed: Add eSPI flash channel support

YH Chung <[email protected]> Tue, 30 Jun 2026 05:02:46 +0000
Newsgroups org.ozlabs.lists.openbmc,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel,org.ozlabs.lists.linux-aspeed
Message-ID <KL1PR0601MB42764147CB9CC731BFB8DB2090F72@KL1PR0601MB4276.apcprd06.prod.outlook.com>
Hi Markus,

> >>> +++ b/drivers/soc/aspeed/espi/aspeed-espi.c
> >> …
> >>> +static void aspeed_espi_flash_rx_work(struct work_struct *work) {
> …
> > Thanks for the suggestion. I agree that guard(mutex) is helpful when a
> > locked section has multiple exit paths. Since this worker currently
> > has a single simple path, I would prefer to keep the explicit
> > mutex_lock()/mutex_unlock() pair for readability. I can switch to
> > guard(mutex) if you think it would be better in this case.
> I hope that development interests can increase more also for the application of
> scope-based resource management.
> 
Thanks for the clarification. I will switch this worker to use guard(mutex)
so that the code follows the scope-based resource management style.

Best regards,
Yun Hsuan