Re: [PATCH 00/42] of: reserved_mem: Introduce devres helpers and convert drivers
Mukesh Ojha <[email protected]> Mon, 6 Jul 2026 18:46:25 +0530
| Newsgroups | org.ozlabs.lists.openbmc,dev.linux.lists.imx,dev.linux.lists.linux-staging,dev.linux.lists.linux-sunxi,org.freedesktop.lists.dri-devel,org.infradead.lists.linux-mediatek,org.kernel.vger.linux-arm-msm,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel,org.kernel.vger.linux-media,org.kernel.vger.linux-mips,org.kernel.vger.linux-mmc,org.kernel.vger.linux-remoteproc,org.kernel.vger.linux-sound,org.kernel.vger.linux-tegra,org.ozlabs.lists.linux-aspeed,org.ozlabs.lists.linuxppc-dev |
|---|---|
| Message-ID | <[email protected]> |
On Mon, Jul 06, 2026 at 01:14:13PM +0100, Mark Brown wrote: > On Sat, Jul 04, 2026 at 01:08:13AM +0530, Mukesh Ojha wrote: > > Drivers using of_reserved_mem_device_init() and its variants must > > manually call of_reserved_mem_device_release() in their remove and > > error-unwind paths. This is repetitive boilerplate that is easy to > > get wrong, and several drivers have open-coded the teardown > > inconsistently or skipped it entirely, leading to dangling reserved > > memory references. > > Just as a general thing, rather than sending a huge cross subsystem > series for something like this it's probably better to just send a > couple of examples, then once the new API is introduced and either has a > pullable tag or has made it to mainline go and do the conversion. This > avoids clogging everyone's inbox with very big serieses. Apologies for this; this is my first series touching these many subsystems, and I also learned the hard way when the entire series was not sent in one shot due to the daily sending limit via git send-email[1], and I had to cut many cc lists for patches 33/42 to 42/42. [1] 4.5.3 Your message has too many recipients. For more information regarding 4.5.3 Google's sending limits, go to 4.5.3 https://support.google.com/mail/?p=TooManyRecipientsError 5a478bee46e88-30f0bbd2362sm49597158eec.20 - gsmtp Thanks for the suggestion; point noted. -- -Mukesh Ojha