Re: [PATCH] pinctrl: Use IRQ trigger mask helpers

Linus Walleij <[email protected]>
Newsgroups org.ozlabs.lists.openbmc,dev.linux.lists.soc,org.infradead.lists.linux-arm-kernel,org.infradead.lists.linux-mediatek,org.kernel.vger.linux-arm-msm,org.kernel.vger.linux-gpio,org.kernel.vger.linux-kernel
Message-ID <CAD++jLm+sfo2pB=cM3v2-ewwdkaomRvTdKh9VVKNU8mJS3wPyA@mail.gmail.com>
On Sun, Aug 2, 2026 at 4:06 PM Maulik Shah <[email protected]> wrote:

> Use IRQ_TYPE_LEVEL_MASK and IRQ_TYPE_EDGE_BOTH instead of open-coded
> trigger type combinations in irqchip callbacks.
>
> No functional change intended.
>
> Assisted-by: Claude:claude-sonnet-5
> Signed-off-by: Maulik Shah <[email protected]>

Nice cleanup, patch applied!

Yours,
Linus Walleij
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.