Re: [PATCH v2 2/2] xen/sched: rename scheduler registration symbols

Jan Beulich <[email protected]>
Newsgroups org.xenproject.lists.xen-devel
Message-ID <[email protected]>
On 04.08.2026 07:53, Furkan Caliskan wrote:
> REGISTER_SCHEDULER(), schedulers[], NUM_SCHEDULERS, and the
> per-arch SCHEDULER_ARRAY linker macro now register and hold
> struct sched_ops instances rather than struct scheduler ones,
> but still carry names describing the old type.
> 
> Rename them to match the current behaviour.
> No functional change.
> 
> Signed-off-by: Furkan Caliskan <[email protected]>
> ---
>  xen/arch/arm/xen.lds.S      |  2 +-
>  xen/arch/ppc/xen.lds.S      |  2 +-
>  xen/arch/riscv/xen.lds.S    |  2 +-
>  xen/arch/x86/xen.lds.S      |  2 +-
>  xen/common/sched/arinc653.c |  2 +-
>  xen/common/sched/core.c     | 33 +++++++++++++++++----------------
>  xen/common/sched/credit.c   |  2 +-
>  xen/common/sched/credit2.c  |  2 +-
>  xen/common/sched/null.c     |  2 +-
>  xen/common/sched/private.h  |  4 ++--
>  xen/common/sched/rt.c       |  2 +-
>  xen/include/xen/xen.lds.h   | 10 +++++-----
>  12 files changed, 33 insertions(+), 32 deletions(-)

I'm not quite sure if all of this is really useful. In many (all?) places
I think "scheduler" as a term is still quite applicable.

One (general) nit though: if already you touch malformed lines (overlong
ones is which prompted this comment), please adjust them to be style-
conformant.

Jan
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.