Re: [PATCH v3] xen/common: add keyhandler to show Xen command line

Jan Beulich <[email protected]>
Newsgroups org.xenproject.lists.xen-devel
Message-ID <[email protected]>
On 11.08.2026 22:56, [email protected] wrote:
> On Tue, Aug 11, 2026 at 10:05:17AM +0200, Roger Pau Monné wrote:
>> On Mon, Aug 10, 2026 at 04:04:01PM -0700, [email protected] wrote:
>>> +static int __init cf_check misc_init(void)
>>> +{
>>> +    register_keyhandler('X', show_hypervisor_info,
>>> +                        "show hypervisor information", 0);
>>
>> "show hypervisor information" seems too generic to me, almost all
>> debug keys could be defined by this sentence TBH.  I think this needs
>> to be more specific, but I'm not sure what's the plan regarding this
>> key.  Is there an intention to print more stuff here, or just the
>> command line?  Knowing the full set of information to be printed might
>> help come up with a better name.
> 
> I will update to "show_cmdline" since I originally planed to expose Xen
> command line only so it is possible to better debug a system when dom0
> becomes almost unresponsive.

Yet as indicated already on v1 (I think) - a precious debug key character
for just the command line seems rather wasteful to me. If it's only the
command line, and if that _really_ needs exposing via a debug key (i.e.
if there are reasonable scenarios where "xl info" cannot be used), perhaps
attach it to e.g. the 'h' key output?

Jan
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.