Re: [docs] [PATCH] dev-manual: correct which package variables support which backends
Quentin Schulz <[email protected]>
| Newsgroups | org.yoctoproject.lists.docs |
|---|---|
| Message-ID | <[email protected]> |
Hi Robert, On 6/12/26 1:57 PM, Robert P. J. Day wrote: > On Fri, 12 Jun 2026, Quentin Schulz wrote: > >> Hi Robert, >> >> On 6/12/26 1:33 PM, Robert P. J. Day via lists.yoctoproject.org wrote: >>> >>> -The following list introduces variables you can use to prevent packages >>> -from being installed into your image. Each of these variables only works >>> -with IPK and RPM package types, not for Debian packages. >>> -Also, you can use these variables from your ``local.conf`` file >>> -or attach them to a specific image recipe by using a recipe name >>> -override. For more detail on the variables, see the descriptions in the >>> -Yocto Project Reference Manual's glossary chapter. >>> +There are three variables you can use to avoid installing particular >>> +packages into the final image -- you can either set these variables >>> +appropriately in your ``local.conf`` file, or attach them to a specific >>> +image recipe by using a recipe name override. >>> >> >> What do you mean by "recipe name override"? > > that phrasing was in the original explanation -- one can set, say, Not verbatim, and it matters here. > PACKAGE_EXCLUDE either globally in local.conf: > > PACKAGE_EXCLUDE = "minicom" > > or attach the exclusion to a specific image by using what the variable ^^^^ here it says "to a specific image" and this patch here says "to a specific image recipe". If you have a recipe name override in an image recipe, it either doesn't work or is useless: my-image.bb: BAD_RECOMMENDATIONS:pn-my-image = "test" is unnecessary complexity for what is simply achieved the same with BAD_RECOMMENDATIONS = "test". The phrasing could hint at: my-image.bb: BAD_RECOMMENDATIONS:pn-some-package-recipe = "test" But this doesn't work, because a recipe (including an image recipe) variable scope is specific to the recipe and cannot impact another recipe, thus this is a no-op. > glossary describes as a "recipe name override": > > https://docs.yoctoproject.org/ref-manual/variables.html#term-PACKAGE_EXCLUDE > > PACKAGE_EXCLUDE:pn-<target image> = "minicom" > > so the phrase "recipe name override" comes from the glossary ... > should it be called something else? > That's ok, it's just combined with the earlier part of the sentence which is confusing or misleading (so the other part of the sentence needs to be fixed). Cheers, Quentin