Re: [docs] why not rename "Maintaining Build Output Quality" to "buildhistory"?

Quentin Schulz <[email protected]> Thu, 25 Jun 2026 10:40:12 +0200
Newsgroups org.yoctoproject.lists.docs
Message-ID <[email protected]>
Hi Robert,

On 6/24/26 8:45 PM, Robert P. J. Day via lists.yoctoproject.org wrote:
> On Wed, 24 Jun 2026, Quentin Schulz wrote:
> 
>>
>>
>> On 6/24/26 11:35 AM, Robert P. J. Day wrote:
>>> On Wed, 24 Jun 2026, Quentin Schulz wrote:
>>>
>>>> On 6/24/26 10:21 AM, Robert P. J. Day via lists.yoctoproject.org wrote:
>>>>>
>>>>> while this section is titled "Maintaining Build Output Quality":
>>>>>
>>>>>      https://docs.yoctoproject.org/dev-manual/build-quality.html
>>>>>
>>>>> it's really solely about how to use "buildhistory", so why not just
>>>>> call it something like "How to use YP buildhistory"? the title seems a
>>>>
>>>> OK but why would I want to use buildhistory? How do I hear about
>>>> buildhistory
>>>> in the first place?
>>>>
>>>>> bit misleading and even a little inaccurate.
>>>>>
>>>>
>>>> What's misleading or inaccurate about it?
>>>>
>>>> """
>>>> The buildhistory class helps you maintain the quality of your build
>>>> output.
>>>> """
>>>>
>>>> This matches the title of the section (which appears in the navigation
>>>> panel
>>>> on the left.
>>>
>>>     because the title suggests a more general approach to maintaining
>>> build quality when the section covers only buildhistory. so why not
>>> just title it that way?
>>>
>>
>> You're looking for ways to improve build quality, will you read a section
>> called "How to use buildhistory" when looking for that?
> 
>    no, but if i was interested in how to use build history, i would
> read a section called "How to Use Build History". you know, the same
> way that, if i wanted to know how to test my packages with ptest, i'd

You would likely search something like "how to test my packages in 
yocto" and not "how to use ptest" because you would need to know about 
ptest to begin with.

> consult a section called "Testing Packages with ptest":
> 

So this would be fine because you have both info.

My point is that the suggested rename is harmful for discovery by 
beginners/newcomers.

So, maybe we could compromise on

Maintaining Build Output Quality with ``buildhistory``

?

Cheers,
Quentin