Re: [docs] [PATCH 2/3] tools/check-glossaries: fix default doc path
"Antonin Godard" <[email protected]> Fri, 03 Jul 2026 13:34:47 +0200
| Newsgroups | org.yoctoproject.lists.docs |
|---|---|
| Message-ID | <[email protected]> |
Hi, On Fri Jul 3, 2026 at 12:22 PM CEST, Quentin Schulz wrote: > Hi Antonin, > > On 7/2/26 3:59 PM, Antonin Godard via lists.yoctoproject.org wrote: >> This default path pointing to the documentation was wrong, fix it. >> >> Signed-off-by: Antonin Godard <[email protected]> >> --- >> documentation/tools/check-glossaries | 2 +- >> 1 file changed, 1 insertion(+), 1 deletion(-) >> >> diff --git a/documentation/tools/check-glossaries b/documentation/tools/check-glossaries >> index 9f1a47126..6bfddcfda 100755 >> --- a/documentation/tools/check-glossaries >> +++ b/documentation/tools/check-glossaries >> @@ -14,7 +14,7 @@ def parse_arguments() -> argparse.Namespace: >> >> parser.add_argument("-d", "--docs-dir", >> type=Path, >> - default=Path(os.path.dirname(os.path.realpath(__file__))) / "documentation", >> + default=Path(os.path.dirname(os.path.realpath(__file__))) / "../", > > Path(__file__).resolve().parent.parent > > is much more readable IMO (and also, we avoid the mental gymnastic of > seeing ../ and having to remove the last directory in the path. > > Reviewed-by: Quentin Schulz <[email protected]> True, we also don't need the os module with this anymore, thanks! v2 incoming. Antonin