org.infradead.lists.linux-snps-arc archive

412 archived articles, newest first (page 1 of 5). Latest articles →

[PATCH] ARC: check user addresses in unaligned access emulation
Mon, 24 Aug 2026 20:37:41 +0000
Jérémy Jean <[email protected]> • #13522
Re: [RFC V3 8/8] mm: Drop pxd_ERROR()
Mon, 24 Aug 2026 10:50:37 -0500
Samuel Holland <[email protected]> • #13521
Re: [RFC V3 1/8] mm: Make ptrval_to_str() generally available
Mon, 24 Aug 2026 10:45:09 -0500
Samuel Holland <[email protected]> • #13520
Re: [RFC V3 1/8] mm: Make ptrval_to_str() generally available
Mon, 24 Aug 2026 10:27:34 +0300
Mike Rapoport <[email protected]> • #13519
Re: [RFC V3 0/8] mm: Drop pxd_ERROR()
Mon, 24 Aug 2026 10:27:34 +0300
Mike Rapoport <[email protected]> • #13518
Re: [RFC V3 1/8] mm: Make ptrval_to_str() generally available
Wed, 19 Aug 2026 08:19:19 +0530
Anshuman Khandual <[email protected]> • #13517
Re: [RFC V3 8/8] mm: Drop pxd_ERROR()
Tue, 18 Aug 2026 19:26:57 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13516
Re: [RFC V3 5/8] sh/mm: Stop using pte_ERROR()
Tue, 18 Aug 2026 19:26:31 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13515
Re: [RFC V3 3/8] loongarch/mm: Stop using pte_ERROR()
Tue, 18 Aug 2026 19:25:53 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13514
Re: [RFC V3 2/8] mm: Stop using pxd_ERROR()
Tue, 18 Aug 2026 19:25:31 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13513
Re: [RFC V3 1/8] mm: Make ptrval_to_str() generally available
Tue, 18 Aug 2026 19:25:07 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13512
[RFC V3 7/8] sh/mm: Stop using pgd_ERROR()
Tue, 18 Aug 2026 09:30:40 +0530
Anshuman Khandual <[email protected]> • #13511
[RFC V3 6/8] sh/mm: Stop using [p4d|pud|pmd]_ERROR()
Tue, 18 Aug 2026 09:30:39 +0530
Anshuman Khandual <[email protected]> • #13510
[RFC V3 5/8] sh/mm: Stop using pte_ERROR()
Tue, 18 Aug 2026 09:30:38 +0530
Anshuman Khandual <[email protected]> • #13509
[RFC V3 8/8] mm: Drop pxd_ERROR()
Tue, 18 Aug 2026 09:30:41 +0530
Anshuman Khandual <[email protected]> • #13508
[RFC V3 4/8] parisc/mm: Directly use generic [pmd|pgd]_clear_bad()
Tue, 18 Aug 2026 09:30:37 +0530
Anshuman Khandual <[email protected]> • #13507
[RFC V3 3/8] loongarch/mm: Stop using pte_ERROR()
Tue, 18 Aug 2026 09:30:36 +0530
Anshuman Khandual <[email protected]> • #13506
[RFC V3 2/8] mm: Stop using pxd_ERROR()
Tue, 18 Aug 2026 09:30:35 +0530
Anshuman Khandual <[email protected]> • #13505
[RFC V3 1/8] mm: Make ptrval_to_str() generally available
Tue, 18 Aug 2026 09:30:34 +0530
Anshuman Khandual <[email protected]> • #13504
[RFC V3 0/8] mm: Drop pxd_ERROR()
Tue, 18 Aug 2026 09:30:33 +0530
Anshuman Khandual <[email protected]> • #13503
Re: [PATCH] ARC: cleanup dead ARC_CANT_LLSC option in Kconfig
Sun, 16 Aug 2026 12:20:03 -0700
Vineet Gupta <[email protected]> • #13502
[PATCH] ARC: cleanup dead ARC_CANT_LLSC option in Kconfig
Sun, 16 Aug 2026 15:22:07 +0100
Julian Braha <[email protected]> • #13501
Re: [RFC V2 6/6] mm: Drop pxd_ERROR()
Thu, 13 Aug 2026 09:18:43 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13500
Re: [RFC V2 3/6] sh/mm: Stop using pte_ERROR()
Thu, 13 Aug 2026 09:18:22 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13499
Re: [RFC V2 6/6] mm: Drop pxd_ERROR()
Thu, 13 Aug 2026 11:33:23 +0530
Anshuman Khandual <[email protected]> • #13498
Re: [RFC V2 4/6] sh/mm: Stop using [p4d|pud|pmd]_ERROR()
Thu, 13 Aug 2026 11:14:48 +0530
Anshuman Khandual <[email protected]> • #13497
Re: [RFC V2 3/6] sh/mm: Stop using pte_ERROR()
Thu, 13 Aug 2026 11:00:53 +0530
Anshuman Khandual <[email protected]> • #13496
Re: [RFC V2 1/6] loongarch/mm: Stop using pte_ERROR()
Thu, 13 Aug 2026 10:04:15 +0530
Anshuman Khandual <[email protected]> • #13495
Re: [RFC V2 6/6] mm: Drop pxd_ERROR()
Wed, 12 Aug 2026 13:33:14 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13494
Re: [RFC V2 5/6] sh/mm: Stop using pgd_ERROR()
Wed, 12 Aug 2026 13:28:44 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13493
Re: [RFC V2 3/6] sh/mm: Stop using pte_ERROR()
Wed, 12 Aug 2026 13:28:23 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13492
Re: [RFC V2 1/6] loongarch/mm: Stop using pte_ERROR()
Wed, 12 Aug 2026 13:27:54 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13491
Re: [RFC V2 4/6] sh/mm: Stop using [p4d|pud|pmd]_ERROR()
Wed, 12 Aug 2026 13:21:28 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13490
Re: [RFC V2 1/6] loongarch/mm: Stop using pte_ERROR()
Wed, 12 Aug 2026 13:19:25 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13489
Re: [RFC V2 2/6] parisc/mm: Directly use generic [pmd|pgd]_clear_bad()
Wed, 12 Aug 2026 13:16:10 +0200
"David Hildenbrand (Arm)" <[email protected]> • #13488
Re: [RFC V2 6/6] mm: Drop pxd_ERROR()
Tue, 11 Aug 2026 14:04:32 +0530
Anshuman Khandual <[email protected]> • #13487
Re: [RFC V2 6/6] mm: Drop pxd_ERROR()
Tue, 11 Aug 2026 08:49:43 +0200
Geert Uytterhoeven <[email protected]> • #13486
[RFC V2 6/6] mm: Drop pxd_ERROR()
Tue, 11 Aug 2026 09:51:19 +0530
Anshuman Khandual <[email protected]> • #13485
[RFC V2 5/6] sh/mm: Stop using pgd_ERROR()
Tue, 11 Aug 2026 09:51:18 +0530
Anshuman Khandual <[email protected]> • #13484
[RFC V2 4/6] sh/mm: Stop using [p4d|pud|pmd]_ERROR()
Tue, 11 Aug 2026 09:51:17 +0530
Anshuman Khandual <[email protected]> • #13483
[RFC V2 3/6] sh/mm: Stop using pte_ERROR()
Tue, 11 Aug 2026 09:51:16 +0530
Anshuman Khandual <[email protected]> • #13482
[RFC V2 2/6] parisc/mm: Directly use generic [pmd|pgd]_clear_bad()
Tue, 11 Aug 2026 09:51:15 +0530
Anshuman Khandual <[email protected]> • #13481
[RFC V2 0/6] mm: Drop pxd_ERROR()
Tue, 11 Aug 2026 09:51:13 +0530
Anshuman Khandual <[email protected]> • #13480
[RFC V2 1/6] loongarch/mm: Stop using pte_ERROR()
Tue, 11 Aug 2026 09:51:14 +0530
Anshuman Khandual <[email protected]> • #13479
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 21 Jul 2026 10:17:49 +0200
Thomas Gleixner <[email protected]> • #13478
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 21 Jul 2026 00:01:03 +0200
Magnus Lindholm <[email protected]> • #13477
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Mon, 20 Jul 2026 21:21:07 +0200
Thomas Gleixner <[email protected]> • #13476
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sun, 19 Jul 2026 13:25:32 +0200
Magnus Lindholm <[email protected]> • #13475
Re: [GIT PULL] ARC fixes for 7.2-rc4
Sun, 19 Jul 2026 04:17:11 +0000
[email protected] • #13474
[GIT PULL] ARC fixes for 7.2-rc4
Sat, 18 Jul 2026 16:23:28 -0700
Vineet Gupta <[email protected]> • #13473
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Mon, 13 Jul 2026 15:06:10 +0800
Guo Ren <[email protected]> • #13472
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Sat, 11 Jul 2026 22:33:16 +0200
Thomas Gleixner <[email protected]> • #13471
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sat, 11 Jul 2026 14:29:12 +0200
Magnus Lindholm <[email protected]> • #13470
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:52:40 +0200
Oleg Nesterov <[email protected]> • #13469
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:32:13 +0200
Michal Suchánek <[email protected]> • #13468
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 13:40:43 +0200
Oleg Nesterov <[email protected]> • #13467
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 13:16:20 +0200
Oleg Nesterov <[email protected]> • #13466
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 01:46:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13465
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Fri, 10 Jul 2026 01:45:19 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13464
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Fri, 10 Jul 2026 01:19:28 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13463
Re: [patch 15/18] x86/entry: Make syscall functions static
Fri, 10 Jul 2026 01:13:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13462
Re: [patch 14/18] entry: Make return type of syscall_trace_enter() bool
Fri, 10 Jul 2026 01:06:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13461
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 00:52:35 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13460
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Fri, 10 Jul 2026 00:40:00 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13459
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Fri, 10 Jul 2026 00:20:46 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13458
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:19:18 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13457
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:15:39 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13456
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:13:32 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13455
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:12:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13454
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:11:04 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13453
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:10:01 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13452
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Fri, 10 Jul 2026 00:04:21 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13451
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:02:27 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #13450
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 09 Jul 2026 13:03:28 -0400
Radu Rendec <[email protected]> • #13449
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 9 Jul 2026 17:26:59 +0100
David Laight <[email protected]> • #13448
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 09:23:47 -0700
Kees Cook <[email protected]> • #13447
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Thu, 9 Jul 2026 09:22:06 -0700
Kees Cook <[email protected]> • #13446
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:22:26 +0200
Philippe Mathieu-Daudé <[email protected]> • #13445
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:20:43 +0200
Philippe Mathieu-Daudé <[email protected]> • #13444
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:18:04 +0200
Philippe Mathieu-Daudé <[email protected]> • #13443
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:17:17 +0200
Philippe Mathieu-Daudé <[email protected]> • #13442
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:51 +0200
Philippe Mathieu-Daudé <[email protected]> • #13441
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:21 +0200
Philippe Mathieu-Daudé <[email protected]> • #13440
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:55 +0200
Philippe Mathieu-Daudé <[email protected]> • #13439
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:11 +0200
Philippe Mathieu-Daudé <[email protected]> • #13438
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 13:12:57 +0200
Philippe Mathieu-Daudé <[email protected]> • #13437
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 10:41:56 +0200
Geert Uytterhoeven <[email protected]> • #13436
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 11:46:07 +0800
Jinjie Ruan <[email protected]> • #13435
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 10:55:27 +0800
Jinjie Ruan <[email protected]> • #13434
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 9 Jul 2026 10:49:49 +0800
Jinjie Ruan <[email protected]> • #13433
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:46:44 +0800
Jinjie Ruan <[email protected]> • #13432
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:44:48 +0800
Jinjie Ruan <[email protected]> • #13431
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:39:17 +0800
Jinjie Ruan <[email protected]> • #13430
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:38:38 +0800
Jinjie Ruan <[email protected]> • #13429
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:38:16 +0800
Jinjie Ruan <[email protected]> • #13428
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:37:44 +0800
Jinjie Ruan <[email protected]> • #13427
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:34:22 +0800
Jinjie Ruan <[email protected]> • #13426
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 10:13:11 +0800
Jinjie Ruan <[email protected]> • #13425
Re: [patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Thu, 9 Jul 2026 10:03:49 +0800
Jinjie Ruan <[email protected]> • #13424
Re: [patch 15/18] x86/entry: Make syscall functions static
Thu, 9 Jul 2026 09:47:56 +0800
Jinjie Ruan <[email protected]> • #13423
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.