org.infradead.lists.linux-snps-arc archive

415 archived articles, newest first (page 4 of 5). Latest articles →

[PATCH v2 21/23] mm/vma: convert as much as we can in mm/vma.c to vma_flags_t
Mon, 16 Mar 2026 13:08:10 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13222
[PATCH v2 22/23] mm/vma: convert vma_modify_flags[_uffd]() to use vma_flags_t
Mon, 16 Mar 2026 13:08:11 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13221
[PATCH v2 19/23] mm/vma: introduce vma_clear_flags[_mask]()
Mon, 16 Mar 2026 13:08:08 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13220
[PATCH v2 20/23] tools/testing/vma: update VMA tests to test vma_clear_flags[_mask]()
Mon, 16 Mar 2026 13:08:09 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13219
[PATCH v2 17/23] mm: convert do_brk_flags() to use vma_flags_t
Mon, 16 Mar 2026 13:08:06 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13218
[PATCH v2 18/23] mm: update vma_supports_mlock() to use new VMA flags
Mon, 16 Mar 2026 13:08:07 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13217
[PATCH v2 16/23] tools/testing/vma: test vma_flags_count,vma[_flags]_test_single_mask
Mon, 16 Mar 2026 13:08:05 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13216
[PATCH v2 12/23] tools/testing/vma: test that legacy flag helpers work correctly
Mon, 16 Mar 2026 13:08:01 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13215
[PATCH v2 15/23] mm: introduce vma_flags_count() and vma[_flags]_test_single_mask()
Mon, 16 Mar 2026 13:08:04 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13214
[PATCH v2 14/23] tools/testing/vma: update VMA flag tests to test vma_test[_any_mask]()
Mon, 16 Mar 2026 13:08:03 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13213
[PATCH v2 13/23] mm/vma: introduce vma_test[_any[_mask]](), and make inlining consistent
Mon, 16 Mar 2026 13:08:02 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13212
[PATCH v2 11/23] mm/vma: introduce [vma_flags,legacy]_to_[legacy,vma_flags]() helpers
Mon, 16 Mar 2026 13:08:00 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13211
[PATCH v2 08/23] tools/testing/vma: add simple test for append_vma_flags()
Mon, 16 Mar 2026 13:07:57 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13210
[PATCH v2 09/23] mm: unexport vm_brk_flags() and eliminate vm_flags parameter
Mon, 16 Mar 2026 13:07:58 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13209
[PATCH v2 10/23] mm/vma: introduce vma_flags_same[_mask/_pair]()
Mon, 16 Mar 2026 13:07:59 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13208
[PATCH v2 07/23] mm/vma: add append_vma_flags() helper
Mon, 16 Mar 2026 13:07:56 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13207
[PATCH v2 05/23] mm/vma: use new VMA flags for sticky flags logic
Mon, 16 Mar 2026 13:07:54 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13206
[PATCH v2 04/23] tools/testing/vma: convert bulk of test code to vma_flags_t
Mon, 16 Mar 2026 13:07:53 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13205
[PATCH v2 06/23] tools/testing/vma: fix VMA flag tests
Mon, 16 Mar 2026 13:07:55 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13204
[PATCH v2 03/23] mm/vma: add further vma_flags_t unions
Mon, 16 Mar 2026 13:07:52 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13203
[PATCH v2 02/23] tools/testing/vma: add unit tests flag empty, diff_pair, and[_mask]
Mon, 16 Mar 2026 13:07:51 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13202
[PATCH v2 01/23] mm/vma: add vma_flags_empty(), vma_flags_and(), vma_flags_diff_pair()
Mon, 16 Mar 2026 13:07:50 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13201
[PATCH v2 00/23] mm/vma: convert vm_flags_t to vma_flags_t in vma code
Mon, 16 Mar 2026 13:07:49 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13200
Re: (subset) [PATCH 00/14] gpio: remove uneeded Kconfig dependencies on OF_GPIO
Fri, 13 Mar 2026 14:43:53 +0100
Bartosz Golaszewski <[email protected]> • #13199
Re: [PATCH 02/20] tools/testing/vma: add unit tests for vma_flags_[empty, diff_pair, and]()
Thu, 12 Mar 2026 19:30:38 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13198
[PATCH 02/20] tools/testing/vma: add unit tests flag empty, diff_pair, and[_mask]
Thu, 12 Mar 2026 19:28:57 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13197
[PATCH 20/20] mm/vma: convert __mmap_region() to use vma_flags_t
Thu, 12 Mar 2026 19:16:18 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13196
[PATCH 19/20] mm/vma: convert vma_modify_flags[_uffd]() to use vma_flags_t
Thu, 12 Mar 2026 19:16:17 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13195
[PATCH 18/20] mm/vma: convert as much as we can in mm/vma.c to vma_flags_t
Thu, 12 Mar 2026 19:16:16 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13194
[PATCH 17/20] tools/testing/vma: update VMA tests to test vma_clear_flags[_mask]()
Thu, 12 Mar 2026 19:16:15 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13193
[PATCH 15/20] tools/testing/vma: update VMA flag tests to test vma_test[_any_mask]()
Thu, 12 Mar 2026 19:16:13 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13192
[PATCH 13/20] mm: convert do_brk_flags() to use vma_flags_t
Thu, 12 Mar 2026 19:16:11 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13191
[PATCH 16/20] mm/vma: introduce vma_clear_flags[_mask]()
Thu, 12 Mar 2026 19:16:14 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13190
[PATCH 14/20] mm/vma: introduce vma_test[_any[_mask]](), and make inlining consistent
Thu, 12 Mar 2026 19:16:12 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13189
[PATCH 12/20] tools/testing/vma: test that legacy flag helpers work correctly
Thu, 12 Mar 2026 19:16:10 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13188
[PATCH 11/20] mm/vma: introduce [vma_flags,legacy]_to_[legacy,vma_flags]() helpers
Thu, 12 Mar 2026 19:16:09 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13187
[PATCH 10/20] mm/vma: introduce vma_flags_same[_mask/_pair]()
Thu, 12 Mar 2026 19:16:08 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13186
[PATCH 09/20] mm: unexport vm_brk_flags() and eliminate vm_flags parameter
Thu, 12 Mar 2026 19:16:07 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13185
[PATCH 08/20] tools/testing/vma: add simple test for append_vma_flags()
Thu, 12 Mar 2026 19:16:06 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13184
[PATCH 07/20] mm/vma: add append_vma_flags() helper
Thu, 12 Mar 2026 19:16:05 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13183
[PATCH 06/20] tools/testing/vma: fix VMA flag tests
Thu, 12 Mar 2026 19:16:04 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13182
[PATCH 04/20] tools/testing/vma: convert bulk of test code to vma_flags_t
Thu, 12 Mar 2026 19:16:02 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13181
[PATCH 05/20] mm/vma: use new VMA flags for sticky flags logic
Thu, 12 Mar 2026 19:16:03 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13180
[PATCH 03/20] mm/vma: add further vma_flags_t unions
Thu, 12 Mar 2026 19:16:01 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13179
[PATCH 02/20] tools/testing/vma: add unit tests for vma_flags_[empty, diff_pair, and]()
Thu, 12 Mar 2026 19:16:00 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13178
[PATCH 01/20] mm/vma: add vma_flags_empty(), vma_flags_and(), vma_flags_diff_pair()
Thu, 12 Mar 2026 19:15:59 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13177
[PATCH 00/20] mm/vma: convert vm_flags_t to vma_flags_t in vma code
Thu, 12 Mar 2026 19:15:58 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #13176
Re: [PATCH 07/14] pinctrl: Kconfig: drop unneeded dependencies on OF_GPIO
Tue, 10 Mar 2026 10:11:32 +0100
Linus Walleij <[email protected]> • #13175
Re: [PATCH 10/14] watchdog: convert the Kconfig dependency on OF_GPIO to OF
Fri, 6 Mar 2026 15:33:36 -0800
Guenter Roeck <[email protected]> • #13174
Re: [PATCH 10/14] watchdog: convert the Kconfig dependency on OF_GPIO to OF
Fri, 6 Mar 2026 15:28:59 -0800
Guenter Roeck <[email protected]> • #13173
Re: [PATCH 10/14] watchdog: convert the Kconfig dependency on OF_GPIO to OF
Wed, 4 Mar 2026 16:47:31 -0800
Guenter Roeck <[email protected]> • #13172
Re: [PATCH] kbuild: Split .modinfo out from ELF_DETAILS
Wed, 04 Mar 2026 17:36:32 -0700
Nathan Chancellor <[email protected]> • #13171
Re: [PATCH 09/14] hwmon: drop unneeded dependency on OF_GPIO
Wed, 4 Mar 2026 13:58:31 -0800
Guenter Roeck <[email protected]> • #13170
Re: [PATCH 02/14] arc: axs10x: drop unneeded dependency on OF_GPIO
Wed, 4 Mar 2026 09:35:19 -0800
Vineet Gupta <[email protected]> • #13169
Re: [PATCH 05/14] regulator: drop unneeded dependencies on OF_GPIO
Wed, 4 Mar 2026 11:23:29 +0000
Mark Brown <[email protected]> • #13168
Re: [PATCH 03/14] powerpc: drop unneeded dependency on OF_GPIO
Wed, 4 Mar 2026 10:18:16 +0100
"Christophe Leroy (CS GROUP)" <[email protected]> • #13167
[PATCH 14/14] media: i2c: drop unneeded dependencies on OF_GPIO
Wed, 04 Mar 2026 10:02:35 +0100
Bartosz Golaszewski <[email protected]> • #13166
[PATCH 13/14] power: reset: drop unneeded dependencies on OF_GPIO
Wed, 04 Mar 2026 10:02:34 +0100
Bartosz Golaszewski <[email protected]> • #13165
[PATCH 12/14] staging: media: max96712: drop unneeded dependency on OF_GPIO
Wed, 04 Mar 2026 10:02:33 +0100
Bartosz Golaszewski <[email protected]> • #13164
[PATCH 10/14] watchdog: convert the Kconfig dependency on OF_GPIO to OF
Wed, 04 Mar 2026 10:02:31 +0100
Bartosz Golaszewski <[email protected]> • #13163
[PATCH 11/14] bus: drop unneeded dependency on OF_GPIO
Wed, 04 Mar 2026 10:02:32 +0100
Bartosz Golaszewski <[email protected]> • #13162
[PATCH 09/14] hwmon: drop unneeded dependency on OF_GPIO
Wed, 04 Mar 2026 10:02:30 +0100
Bartosz Golaszewski <[email protected]> • #13161
[PATCH 08/14] leds: Kconfig: drop unneeded dependency on OF_GPIO
Wed, 04 Mar 2026 10:02:29 +0100
Bartosz Golaszewski <[email protected]> • #13160
[PATCH 06/14] gpio: drop unneeded Kconfig dependencies on OF_GPIO
Wed, 04 Mar 2026 10:02:27 +0100
Bartosz Golaszewski <[email protected]> • #13159
[PATCH 07/14] pinctrl: Kconfig: drop unneeded dependencies on OF_GPIO
Wed, 04 Mar 2026 10:02:28 +0100
Bartosz Golaszewski <[email protected]> • #13158
[PATCH 05/14] regulator: drop unneeded dependencies on OF_GPIO
Wed, 04 Mar 2026 10:02:26 +0100
Bartosz Golaszewski <[email protected]> • #13157
[PATCH 04/14] net: mdio: drop unneeded dependency on OF_GPIO
Wed, 04 Mar 2026 10:02:25 +0100
Bartosz Golaszewski <[email protected]> • #13156
[PATCH 03/14] powerpc: drop unneeded dependency on OF_GPIO
Wed, 04 Mar 2026 10:02:24 +0100
Bartosz Golaszewski <[email protected]> • #13155
[PATCH 02/14] arc: axs10x: drop unneeded dependency on OF_GPIO
Wed, 04 Mar 2026 10:02:23 +0100
Bartosz Golaszewski <[email protected]> • #13154
[PATCH 01/14] arm64: Kconfig: drop unneeded dependency on OF_GPIO
Wed, 04 Mar 2026 10:02:22 +0100
Bartosz Golaszewski <[email protected]> • #13153
[PATCH 00/14] gpio: remove uneeded Kconfig dependencies on OF_GPIO
Wed, 04 Mar 2026 10:02:21 +0100
Bartosz Golaszewski <[email protected]> • #13152
Re: [PATCH v3 23/29] arch, mm: consolidate initialization of nodes, zones and memory map
Fri, 27 Feb 2026 22:31:41 +0200
Mike Rapoport <[email protected]> • #13151
Re: [PATCH v3 23/29] arch, mm: consolidate initialization of nodes, zones and memory map
Fri, 27 Feb 2026 16:14:42 +0100
Vlastimil Babka <[email protected]> • #13150
[PATCH] kbuild: Split .modinfo out from ELF_DETAILS
Wed, 25 Feb 2026 15:02:51 -0700
Nathan Chancellor <[email protected]> • #13149
Re: [PATCH v3 24/29] arch, mm: consolidate initialization of SPARSE memory model
Wed, 25 Feb 2026 23:08:38 +0530
Ritesh Harjani (IBM) <[email protected]> • #13148
Re: [PATCH v3 24/29] arch, mm: consolidate initialization of SPARSE memory model
Wed, 25 Feb 2026 18:25:24 +0200
Mike Rapoport <[email protected]> • #13147
Re: [PATCH v3 24/29] arch, mm: consolidate initialization of SPARSE memory model
Wed, 25 Feb 2026 09:00:35 +0530
Ritesh Harjani (IBM) <[email protected]> • #13146
Re: [PATCH v2 4/4] mm: cache struct page for empty_zero_page and return it from ZERO_PAGE()
Mon, 23 Feb 2026 17:20:13 +0100
"David Hildenbrand (Arm)" <[email protected]> • #13145
Re: [PATCH v2 3/4] arch, mm: consolidate empty_zero_page
Mon, 23 Feb 2026 17:18:24 +0100
"David Hildenbrand (Arm)" <[email protected]> • #13144
Re: [PATCH v2 1/4] mm: don't special case !MMU for is_zero_pfn() and my_zero_pfn()
Mon, 23 Feb 2026 17:16:05 +0100
"David Hildenbrand (Arm)" <[email protected]> • #13143
Re: [PATCH] arc: axs10x: drop unneeded dependency on OF_GPIO
Mon, 23 Feb 2026 11:51:48 +0100
Bartosz Golaszewski <[email protected]> • #13142
Re: [PATCH 3.5] arm: make initialization of zero page independent of the memory map (was Re: [PATCH v2 22/28] arch, mm: consolidate initialization of nodes, zones and memory map)
Fri, 20 Feb 2026 04:11:02 +0000
[email protected] • #13141
Re: [PATCH v3 00/29] arch, mm: consolidate hugetlb early reservation
Fri, 20 Feb 2026 04:10:42 +0000
[email protected] • #13140
Re: [PATCH v3 4/4] mm: cache struct page for empty_zero_page and return it from ZERO_PAGE()
Thu, 12 Feb 2026 13:40:04 -0500
"Liam R. Howlett" <[email protected]> • #13139
Re: [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Thu, 12 Feb 2026 13:38:16 -0500
"Liam R. Howlett" <[email protected]> • #13138
Re: [PATCH v3 2/4] mm: rename my_zero_pfn() to zero_pfn()
Thu, 12 Feb 2026 13:33:28 -0500
"Liam R. Howlett" <[email protected]> • #13137
Re: [PATCH v3 1/4] mm: don't special case !MMU for is_zero_pfn() and my_zero_pfn()
Thu, 12 Feb 2026 13:30:20 -0500
"Liam R. Howlett" <[email protected]> • #13136
Re: [PATCH v3 2/4] mm: rename my_zero_pfn() to zero_pfn()
Thu, 12 Feb 2026 16:28:23 +0100
Vlastimil Babka <[email protected]> • #13135
Re: [PATCH v3 4/4] mm: cache struct page for empty_zero_page and return it from ZERO_PAGE()
Thu, 12 Feb 2026 10:08:49 +0100
"David Hildenbrand (Arm)" <[email protected]> • #13134
Re: [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Thu, 12 Feb 2026 10:04:03 +0100
"David Hildenbrand (Arm)" <[email protected]> • #13133
Re: [PATCH v3 2/4] mm: rename my_zero_pfn() to zero_pfn()
Thu, 12 Feb 2026 10:01:27 +0100
"David Hildenbrand (Arm)" <[email protected]> • #13132
Re: [PATCH v3 1/4] mm: don't special case !MMU for is_zero_pfn() and my_zero_pfn()
Thu, 12 Feb 2026 09:58:24 +0100
"David Hildenbrand (Arm)" <[email protected]> • #13131
Re: [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Thu, 12 Feb 2026 09:38:42 +0100
Andreas Larsson <[email protected]> • #13130
Re: [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Wed, 11 Feb 2026 23:33:09 -0600
Dinh Nguyen <[email protected]> • #13129
Re: [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Wed, 11 Feb 2026 21:14:19 +0100
Magnus Lindholm <[email protected]> • #13128
[PATCH v3 4/4] mm: cache struct page for empty_zero_page and return it from ZERO_PAGE()
Wed, 11 Feb 2026 12:31:41 +0200
Mike Rapoport <[email protected]> • #13127
[PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Wed, 11 Feb 2026 12:31:40 +0200
Mike Rapoport <[email protected]> • #13126
[PATCH v3 2/4] mm: rename my_zero_pfn() to zero_pfn()
Wed, 11 Feb 2026 12:31:39 +0200
Mike Rapoport <[email protected]> • #13125
[PATCH v3 1/4] mm: don't special case !MMU for is_zero_pfn() and my_zero_pfn()
Wed, 11 Feb 2026 12:31:38 +0200
Mike Rapoport <[email protected]> • #13124
[PATCH v3 0/4] arch, mm: consolidate empty_zero_page
Wed, 11 Feb 2026 12:31:37 +0200
Mike Rapoport <[email protected]> • #13123
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.