org.kernel.vger.ceph-devel archive

654 archived articles, newest first (page 1 of 7). Latest articles →

Re: [PATCH v1 03/12] fsnotify: don't hold a spin_lock across fsnotify_recalc_mask() calls.
Sun, 23 Aug 2026 11:21:23 +1000
NeilBrown <[email protected]> • #61590
[PATCH] ceph: keep dentry in cache when inode still holds caps
Fri, 21 Aug 2026 19:28:51 -0700
Xiubo Li via B4 Relay <[email protected]> • #61589
Re: [PATCH] libceph: Re-establish the FIPS keylength check in the Ceph code
Fri, 21 Aug 2026 19:36:36 +0000
Eric Biggers <[email protected]> • #61588
Re: [PATCH] libceph: Re-establish the FIPS keylength check in the Ceph code
Fri, 21 Aug 2026 17:53:12 +0000
Eric Biggers <[email protected]> • #61587
[PATCH] libceph: Re-establish the FIPS keylength check in the Ceph code
Fri, 21 Aug 2026 16:43:22 +0200
Thomas Huth <[email protected]> • #61586
[PATCH v4] ceph: add 'lazyio' mount option to kclient
Thu, 20 Aug 2026 23:37:54 -0700
Xiubo Li via B4 Relay <[email protected]> • #61585
Re: [v3] ceph: add 'lazyio' mount option to kclient
Thu, 20 Aug 2026 20:08:15 -0700
Xiubo Li <[email protected]> • #61584
Re: [v3] ceph: add 'lazyio' mount option to kclient
Thu, 20 Aug 2026 18:43:37 +0000
Alex Markuze <[email protected]> • #61583
Re: [PATCH v2 13/18] VFS: don't move dentries in d_sib list when they have the same parent
Thu, 20 Aug 2026 09:39:00 -0400
"Chuck Lever" <[email protected]> • #61582
[PATCH v3 08/14] ceph: add bout and boutc wrappers for BLOG
Thu, 20 Aug 2026 12:56:11 +0000
Alex Markuze <[email protected]> • #61581
[PATCH v3 11/14] ceph: convert VFS inode and directory paths to bout
Thu, 20 Aug 2026 12:56:14 +0000
Alex Markuze <[email protected]> • #61580
[PATCH v3 13/14] ceph: convert capability and snapshot paths to bout
Thu, 20 Aug 2026 12:56:16 +0000
Alex Markuze <[email protected]> • #61579
[PATCH v3 10/14] ceph: add BLOG debugfs interface
Thu, 20 Aug 2026 12:56:13 +0000
Alex Markuze <[email protected]> • #61578
[PATCH v3 12/14] ceph: convert VFS data I/O paths to bout
Thu, 20 Aug 2026 12:56:15 +0000
Alex Markuze <[email protected]> • #61577
[PATCH v3 14/14] ceph: convert remaining helper paths to bout
Thu, 20 Aug 2026 12:56:17 +0000
Alex Markuze <[email protected]> • #61576
[PATCH v3 05/14] ceph: add BLOG logger core
Thu, 20 Aug 2026 12:56:08 +0000
Alex Markuze <[email protected]> • #61575
[PATCH v3 09/14] ceph: switch MDS request plumbing to struct ceph_journal_info
Thu, 20 Aug 2026 12:56:12 +0000
Alex Markuze <[email protected]> • #61574
[PATCH v3 03/14] ceph: add BLOG page-fragment allocator
Thu, 20 Aug 2026 12:56:06 +0000
Alex Markuze <[email protected]> • #61573
[PATCH v3 07/14] ceph: add Ceph BLOG scaffolding
Thu, 20 Aug 2026 12:56:10 +0000
Alex Markuze <[email protected]> • #61572
[PATCH v3 06/14] ceph: add BLOG per-module context management
Thu, 20 Aug 2026 12:56:09 +0000
Alex Markuze <[email protected]> • #61571
[PATCH v3 04/14] ceph: add BLOG magazine batch allocator
Thu, 20 Aug 2026 12:56:07 +0000
Alex Markuze <[email protected]> • #61570
[PATCH v3 00/14] ceph: add binary logging (BLOG) for CephFS
Thu, 20 Aug 2026 12:56:03 +0000
Alex Markuze <[email protected]> • #61569
[PATCH v3 01/14] ceph: add BLOG private headers
Thu, 20 Aug 2026 12:56:04 +0000
Alex Markuze <[email protected]> • #61568
[PATCH v3 02/14] ceph: add BLOG deserialization support
Thu, 20 Aug 2026 12:56:05 +0000
Alex Markuze <[email protected]> • #61567
Re: [v3] ceph: force a cap message when a deferred revoke can't be acked immediately
Thu, 20 Aug 2026 07:24:35 +0000
Alex Markuze <[email protected]> • #61566
Re: ceph: don't unregister an MDS session before removing its caps
Thu, 20 Aug 2026 07:23:23 +0000
Alex Markuze <[email protected]> • #61565
Re: [v2] ceph: parallelize object copy in ceph_do_objects_copy()
Thu, 20 Aug 2026 07:19:56 +0000
Alex Markuze <[email protected]> • #61564
[PATCH v3] ceph: add 'lazyio' mount option to kclient
Wed, 19 Aug 2026 20:35:53 -0700
Xiubo Li via B4 Relay <[email protected]> • #61563
Re: [PATCH v1 03/12] fsnotify: don't hold a spin_lock across fsnotify_recalc_mask() calls.
Wed, 19 Aug 2026 18:21:48 +0200
Jan Kara <[email protected]> • #61562
Re: [PATCH] libceph: use iov_iter_extract_pages() in ceph_msg_data_iter_next()
Wed, 19 Aug 2026 16:26:36 +0200
Christoph Hellwig <[email protected]> • #61561
Re: [PATCH] libceph: use iov_iter_extract_pages() in ceph_msg_data_iter_next()
Wed, 19 Aug 2026 17:07:05 +0300
Tal Zussman <[email protected]> • #61560
Re: [v4,0/10] ceph: convert writeback path to folios
Wed, 19 Aug 2026 16:58:44 +0300
Tal Zussman <[email protected]> • #61559
Re: [v4,0/10] ceph: convert writeback path to folios
Wed, 19 Aug 2026 11:07:18 +0000
Alex Markuze <[email protected]> • #61558
Re: libceph: use iov_iter_extract_pages() in ceph_msg_data_iter_next()
Wed, 19 Aug 2026 11:01:52 +0000
Alex Markuze <[email protected]> • #61557
Re: [PATCH v2] libceph: remove ceph_put_page_vector()
Wed, 19 Aug 2026 10:25:13 +0000
Alex Markuze <[email protected]> • #61556
Re: libceph: reject buckets with mismatched CRUSH ids
Wed, 19 Aug 2026 10:21:50 +0000
Alex Markuze <[email protected]> • #61555
Re: [PATCH v4] net/ceph/messenger: support IPv6 Link-Local with scope identifier
Wed, 19 Aug 2026 10:13:00 +0000
Alex Markuze <[email protected]> • #61554
Re: [PATCH v1 03/12] fsnotify: don't hold a spin_lock across fsnotify_recalc_mask() calls.
Wed, 19 Aug 2026 11:09:08 +0200
Amir Goldstein <[email protected]> • #61553
Re: [PATCH] libceph: use iov_iter_extract_pages() in ceph_msg_data_iter_next()
Wed, 19 Aug 2026 07:44:13 +0200
Christoph Hellwig <[email protected]> • #61552
Re: [PATCH v1 03/12] fsnotify: don't hold a spin_lock across fsnotify_recalc_mask() calls.
Wed, 19 Aug 2026 09:30:34 +1000
NeilBrown <[email protected]> • #61551
[PATCH v3] ceph: force a cap message when a deferred revoke can't be acked immediately
Tue, 18 Aug 2026 20:40:05 +0200
Max Kellermann <[email protected]> • #61550
[PATCH v4 12/12] fs/ceph: remove redundant inode number from ceph_inode_info
Tue, 18 Aug 2026 20:11:44 +0200
Max Kellermann <[email protected]> • #61549
[PATCH v4 09/12] fs/ceph/super.h: add `const` to helpers
Tue, 18 Aug 2026 20:11:41 +0200
Max Kellermann <[email protected]> • #61548
[PATCH v4 11/12] fs/ceph: use ceph_vino() etc. instead of accessing i_vino directly
Tue, 18 Aug 2026 20:11:43 +0200
Max Kellermann <[email protected]> • #61547
[PATCH v4 08/12] fs/ceph: remove i_truncate_mutex, use i_fragtree_mutex for both
Tue, 18 Aug 2026 20:11:40 +0200
Max Kellermann <[email protected]> • #61546
[PATCH v4 06/12] fs/ceph: consistently use `u32` for `time_warp_seq`
Tue, 18 Aug 2026 20:11:38 +0200
Max Kellermann <[email protected]> • #61545
[PATCH v4 07/12] fs/ceph/super: reorder fields to eliminate padding holes
Tue, 18 Aug 2026 20:11:39 +0200
Max Kellermann <[email protected]> • #61544
[PATCH v4 05/12] fs/ceph/super.h: convert ceph_cap_snap.writing fields to `bool`
Tue, 18 Aug 2026 20:11:37 +0200
Max Kellermann <[email protected]> • #61543
[PATCH v4 10/12] fs/ceph/super.h: add helper ceph_in_snap()
Tue, 18 Aug 2026 20:11:42 +0200
Max Kellermann <[email protected]> • #61542
[PATCH v4 04/12] fs/ceph/super.h: convert ceph_inode_xattr fields to `bool`
Tue, 18 Aug 2026 20:11:36 +0200
Max Kellermann <[email protected]> • #61541
[PATCH v4 03/12] include/ceph/ceph_fs.h: convert `pool_id` to u32
Tue, 18 Aug 2026 20:11:35 +0200
Max Kellermann <[email protected]> • #61540
[PATCH v4 02/12] fs/ceph/super: make field `i_truncate_pagecache_size` optional
Tue, 18 Aug 2026 20:11:34 +0200
Max Kellermann <[email protected]> • #61539
[PATCH v4 01/12] fs/ceph/super: remove unused field `i_cap_migration_resv`
Tue, 18 Aug 2026 20:11:33 +0200
Max Kellermann <[email protected]> • #61538
[PATCH v4 00/12] fs/ceph: optimize struct layouts
Tue, 18 Aug 2026 20:11:32 +0200
Max Kellermann <[email protected]> • #61537
[PATCH] ceph: don't unregister an MDS session before removing its caps
Tue, 18 Aug 2026 18:50:53 +0200
Max Kellermann <[email protected]> • #61536
Re: [bug report] libceph: Oversized front segment in CEPH_MSG_OSD_OPREPLY not in all cases correctly handled
Tue, 18 Aug 2026 09:49:59 -0700
Viacheslav Dubeyko <[email protected]> • #61535
Re: [PATCH v3] libceph: reset OSD session when keepalive2 acks stop arriving
Tue, 18 Aug 2026 10:58:04 -0500
Chris Arges <[email protected]> • #61534
[PATCH v5 5/5] ceph: narrow mdsc->mutex scope in replay_unsafe_requests
Tue, 18 Aug 2026 03:58:12 -0700
Xiubo Li via B4 Relay <[email protected]> • #61533
[PATCH v5 4/5] ceph: move mdsc->mutex into __do_request()
Tue, 18 Aug 2026 03:58:11 -0700
Xiubo Li via B4 Relay <[email protected]> • #61532
[PATCH v5 3/5] ceph: add wait_list_lock for wait-list serialization
Tue, 18 Aug 2026 03:58:10 -0700
Xiubo Li via B4 Relay <[email protected]> • #61531
[PATCH v5 2/5] ceph: replace the request_tree rbtree with an xarray keyed by r_tid
Tue, 18 Aug 2026 03:58:09 -0700
Xiubo Li via B4 Relay <[email protected]> • #61530
[PATCH v5 1/5] ceph: use READ_ONCE/WRITE_ONCE for oldest_tid
Tue, 18 Aug 2026 03:58:08 -0700
Xiubo Li via B4 Relay <[email protected]> • #61529
[PATCH v5 0/5] ceph: reduce mdsc->mutex contention in the cephfs kclient
Tue, 18 Aug 2026 03:58:07 -0700
Xiubo Li via B4 Relay <[email protected]> • #61528
Re: [PATCH v3] libceph: reset OSD session when keepalive2 acks stop arriving
Tue, 18 Aug 2026 09:56:54 +0000
Alex Markuze <[email protected]> • #61527
Re: [PATCH v4 0/5] ceph: reduce mdsc->mutex contention in the cephfs kclient
Mon, 17 Aug 2026 19:06:44 -0700
Xiubo Li <[email protected]> • #61526
[PATCH v2] ceph: parallelize object copy in ceph_do_objects_copy()
Mon, 17 Aug 2026 18:47:50 -0700
Xiubo Li via B4 Relay <[email protected]> • #61525
[PATCH] libceph: use iov_iter_extract_pages() in ceph_msg_data_iter_next()
Mon, 17 Aug 2026 18:16:56 -0400
Tal Zussman <[email protected]> • #61524
[PATCH v2] libceph: remove ceph_put_page_vector()
Mon, 17 Aug 2026 15:29:17 -0400
Tal Zussman <[email protected]> • #61523
[PATCH v4 10/10] ceph: rename ceph_check_page_before_write() to ceph_check_folio_before_write()
Mon, 17 Aug 2026 14:55:26 -0400
Tal Zussman <[email protected]> • #61522
[PATCH v4 09/10] ceph: remove ceph_fscrypt_pagecache_page() and ceph_fscrypt_page_offset()
Mon, 17 Aug 2026 14:55:25 -0400
Tal Zussman <[email protected]> • #61521
[PATCH v4 08/10] ceph: convert page cleanup loop in writepages_finish() to folios
Mon, 17 Aug 2026 14:55:24 -0400
Tal Zussman <[email protected]> • #61520
[PATCH v4 07/10] ceph: remove page remnants from write_folio_nounlock()
Mon, 17 Aug 2026 14:55:23 -0400
Tal Zussman <[email protected]> • #61519
[PATCH v4 06/10] ceph: convert ceph_submit_write() to folios
Mon, 17 Aug 2026 14:55:22 -0400
Tal Zussman <[email protected]> • #61518
[PATCH v4 05/10] ceph: convert get_writepages_data_length() to folios
Mon, 17 Aug 2026 14:55:21 -0400
Tal Zussman <[email protected]> • #61517
[PATCH v4 04/10] ceph: convert ceph_wait_until_current_writes_complete() to folios
Mon, 17 Aug 2026 14:55:20 -0400
Tal Zussman <[email protected]> • #61516
[PATCH v4 03/10] ceph: add ceph_folio_snap_context()
Mon, 17 Aug 2026 14:55:19 -0400
Tal Zussman <[email protected]> • #61515
[PATCH v4 01/10] ceph: fix error handling when the OSD client is stopping in ceph_submit_write()
Mon, 17 Aug 2026 14:55:17 -0400
Tal Zussman <[email protected]> • #61514
[PATCH v4 02/10] ceph: wait for pending fscache write in write_folio_nounlock()
Mon, 17 Aug 2026 14:55:18 -0400
Tal Zussman <[email protected]> • #61513
[PATCH v4 00/10] ceph: convert writeback path to folios
Mon, 17 Aug 2026 14:55:16 -0400
Tal Zussman <[email protected]> • #61512
Re: [PATCH v1 03/12] fsnotify: don't hold a spin_lock across fsnotify_recalc_mask() calls.
Mon, 17 Aug 2026 15:27:28 +0200
Amir Goldstein <[email protected]> • #61511
Re: [PATCH v2] ceph: force a cap message when a deferred revoke can't be acked immediately
Mon, 17 Aug 2026 18:08:33 +0530
Venky Shankar <[email protected]> • #61510
Re: [PATCH v3 00/12] fs/ceph: optimize struct layouts
Mon, 17 Aug 2026 11:08:39 +0000
Alex Markuze <[email protected]> • #61509
Re: [PATCH v4 0/5] ceph: reduce mdsc->mutex contention in the cephfs kclient
Mon, 17 Aug 2026 11:05:20 +0000
Alex Markuze <[email protected]> • #61508
Re: [PATCH v1 03/12] fsnotify: don't hold a spin_lock across fsnotify_recalc_mask() calls.
Mon, 17 Aug 2026 13:03:19 +0200
Jan Kara <[email protected]> • #61507
Re: [PATCH] ceph: parallelize object copy in ceph_do_objects_copy()
Sun, 16 Aug 2026 19:26:28 -0700
Xiubo Li <[email protected]> • #61506
Re: (subset) [PATCH v5 00/16] Add dmabuf read/write via io_uring
Sat, 15 Aug 2026 18:01:15 -0600
Jens Axboe <[email protected]> • #61505
[PATCH] libceph: reject buckets with mismatched CRUSH ids
Sat, 15 Aug 2026 21:46:37 +0000
Jérémy Jean <[email protected]> • #61504
Re: [PATCH RFC/RFT v2 00/18] Fix easy bits of the negative dentry problem
Sat, 15 Aug 2026 16:12:31 +1000
NeilBrown <[email protected]> • #61503
Re: [PATCH RFC/RFT v2 00/18] Fix easy bits of the negative dentry problem
Sat, 15 Aug 2026 06:03:49 +0100
Al Viro <[email protected]> • #61502
[PATCH v2 18/18] autofs: change get_next_positive_dentry() to NOT accept NULL for start-up
Sat, 15 Aug 2026 14:21:35 +1000
NeilBrown <[email protected]> • #61501
[PATCH v2 17/18] autofs: replace positive_after() with d_scan_positives()
Sat, 15 Aug 2026 14:21:34 +1000
NeilBrown <[email protected]> • #61500
[PATCH v2 16/18] libfs: rename and export scan_positives()
Sat, 15 Aug 2026 14:21:33 +1000
NeilBrown <[email protected]> • #61499
[PATCH v2 15/18] libfs: remove cond_resched() from scan_positives()
Sat, 15 Aug 2026 14:21:32 +1000
NeilBrown <[email protected]> • #61498
[PATCH v2 14/18] Call cond_reshed() as needed in d_for_each_positive_child().
Sat, 15 Aug 2026 14:21:31 +1000
NeilBrown <[email protected]> • #61497
[PATCH v2 13/18] VFS: don't move dentries in d_sib list when they have the same parent
Sat, 15 Aug 2026 14:21:30 +1000
NeilBrown <[email protected]> • #61496
[PATCH v2 12/18] autofs: don't hold ->lookup_lock in get_next_positive_*
Sat, 15 Aug 2026 14:21:29 +1000
NeilBrown <[email protected]> • #61495
[PATCH v2 11/18] libfs: replace find_positive_dentry() with scan_positives()
Sat, 15 Aug 2026 14:21:28 +1000
NeilBrown <[email protected]> • #61494
[PATCH v2 10/18] libfs: allow scan_positives() to be called without a cursor.
Sat, 15 Aug 2026 14:21:27 +1000
NeilBrown <[email protected]> • #61493
[PATCH v2 09/18] libfs: change scan_positives() to use d_for_each_positive_child_continue()
Sat, 15 Aug 2026 14:21:26 +1000
NeilBrown <[email protected]> • #61492
[PATCH v2 08/18] libfs: simplify scan_positives()
Sat, 15 Aug 2026 14:21:25 +1000
NeilBrown <[email protected]> • #61491
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.