org.kernel.vger.linux-hexagon

6682 articles on record, showing the most recent 50.

Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 21 Jul 2026 08:17:49 +0000
Thomas Gleixner <[email protected]> • #6683
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Mon, 20 Jul 2026 22:01:03 +0000
Magnus Lindholm <[email protected]> • #6682
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Mon, 20 Jul 2026 19:21:07 +0000
Thomas Gleixner <[email protected]> • #6681
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sun, 19 Jul 2026 11:25:32 +0000
Magnus Lindholm <[email protected]> • #6680
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Tue, 14 Jul 2026 08:20:20 +0000
"Michal Such??nek" <[email protected]> • #6679
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Mon, 13 Jul 2026 07:06:10 +0000
Guo Ren <[email protected]> • #6678
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Sat, 11 Jul 2026 20:33:16 +0000
Thomas Gleixner <[email protected]> • #6677
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sat, 11 Jul 2026 12:29:12 +0000
Magnus Lindholm <[email protected]> • #6676
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 15:20:03 +0000
"Michal Such??nek" <[email protected]> • #6675
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 12:52:40 +0000
Oleg Nesterov <[email protected]> • #6674
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 12:32:13 +0000
"Michal Such??nek" <[email protected]> • #6673
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 11:40:43 +0000
Oleg Nesterov <[email protected]> • #6672
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 11:16:20 +0000
Oleg Nesterov <[email protected]> • #6671
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 11:01:02 +0000
"Michal Such??nek" <[email protected]> • #6670
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 10:42:29 +0000
"Michal Such??nek" <[email protected]> • #6669
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 20:16:15 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6668
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Thu, 09 Jul 2026 20:15:19 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6667
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Thu, 09 Jul 2026 19:49:28 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6666
Re: [patch 15/18] x86/entry: Make syscall functions static
Thu, 09 Jul 2026 19:43:15 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6665
Re: [patch 14/18] entry: Make return type of syscall_trace_enter() bool
Thu, 09 Jul 2026 19:36:23 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6664
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 09 Jul 2026 19:22:35 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6663
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Thu, 09 Jul 2026 19:10:00 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6662
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 09 Jul 2026 18:50:46 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6661
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 09 Jul 2026 18:49:18 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6660
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 18:45:39 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6659
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 18:43:32 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6658
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 18:42:23 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6657
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 18:41:04 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6656
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 18:40:01 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6655
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 09 Jul 2026 18:34:21 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6654
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 09 Jul 2026 18:32:27 +0000
Mukesh Kumar Chaurasiya <[email protected]> • #6653
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 09 Jul 2026 17:03:28 +0000
Radu Rendec <[email protected]> • #6652
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 09 Jul 2026 16:26:59 +0000
David Laight <[email protected]> • #6651
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 09 Jul 2026 16:23:47 +0000
Kees Cook <[email protected]> • #6650
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Thu, 09 Jul 2026 16:22:06 +0000
Kees Cook <[email protected]> • #6649
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 09 Jul 2026 11:22:26 +0000
"Philippe Mathieu-Daud??" <[email protected]> • #6648
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 09 Jul 2026 11:20:43 +0000
"Philippe Mathieu-Daud??" <[email protected]> • #6647
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 11:18:04 +0000
"Philippe Mathieu-Daud??" <[email protected]> • #6646
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 11:17:17 +0000
"Philippe Mathieu-Daud??" <[email protected]> • #6645
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 11:16:51 +0000
"Philippe Mathieu-Daud??" <[email protected]> • #6644
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 11:16:21 +0000
"Philippe Mathieu-Daud??" <[email protected]> • #6643
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 11:15:55 +0000
"Philippe Mathieu-Daud??" <[email protected]> • #6642
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 11:15:11 +0000
"Philippe Mathieu-Daud??" <[email protected]> • #6641
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 09 Jul 2026 11:12:57 +0000
"Philippe Mathieu-Daud??" <[email protected]> • #6640
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 09 Jul 2026 08:41:56 +0000
Geert Uytterhoeven <[email protected]> • #6639
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 03:46:07 +0000
Jinjie Ruan <[email protected]> • #6638
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 09 Jul 2026 02:55:27 +0000
Jinjie Ruan <[email protected]> • #6637
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 09 Jul 2026 02:49:49 +0000
Jinjie Ruan <[email protected]> • #6636
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 02:46:44 +0000
Jinjie Ruan <[email protected]> • #6635
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 09 Jul 2026 02:44:48 +0000
Jinjie Ruan <[email protected]> • #6634