org.kernel.vger.linux-openrisc archive

496 archived articles, newest first (page 3 of 5). Latest articles →

[RFC PATCH 04/34] LoongArch: mm: define pud_leaf() only when PUD exists
Mon, 13 Jul 2026 14:55:43 +0100
Yeoreum Yun <[email protected]> • #7442
[RFC PATCH 03/34] ARM: mm: remove custom pgdp_get()
Mon, 13 Jul 2026 14:55:42 +0100
Yeoreum Yun <[email protected]> • #7441
[RFC PATCH 02/34] ARM: mm: make 2-level pgd_t a scalar
Mon, 13 Jul 2026 14:55:41 +0100
Yeoreum Yun <[email protected]> • #7440
[RFC PATCH 01/34] ARM: mm: make nommu pgd_t a scalar
Mon, 13 Jul 2026 14:55:40 +0100
Yeoreum Yun <[email protected]> • #7439
[RFC PATCH 00/34] mm: optimize unnecessary loads due to ptep_get() and friends out
Mon, 13 Jul 2026 14:55:39 +0100
Yeoreum Yun <[email protected]> • #7438
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Mon, 13 Jul 2026 15:06:10 +0800
Guo Ren <[email protected]> • #7437
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Sat, 11 Jul 2026 22:33:16 +0200
Thomas Gleixner <[email protected]> • #7436
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sat, 11 Jul 2026 14:29:12 +0200
Magnus Lindholm <[email protected]> • #7435
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 17:20:03 +0200
Michal Suchánek <[email protected]> • #7434
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:52:40 +0200
Oleg Nesterov <[email protected]> • #7433
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:32:13 +0200
Michal Suchánek <[email protected]> • #7432
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 13:40:43 +0200
Oleg Nesterov <[email protected]> • #7431
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 13:16:20 +0200
Oleg Nesterov <[email protected]> • #7430
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 13:01:02 +0200
Michal Suchánek <[email protected]> • #7429
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 12:42:29 +0200
Michal Suchánek <[email protected]> • #7428
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 01:46:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7427
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Fri, 10 Jul 2026 01:45:19 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7426
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Fri, 10 Jul 2026 01:19:28 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7425
Re: [patch 15/18] x86/entry: Make syscall functions static
Fri, 10 Jul 2026 01:13:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7424
Re: [patch 14/18] entry: Make return type of syscall_trace_enter() bool
Fri, 10 Jul 2026 01:06:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7423
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 00:52:35 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7422
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Fri, 10 Jul 2026 00:40:00 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7421
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Fri, 10 Jul 2026 00:20:46 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7420
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:19:18 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7419
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:15:39 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7418
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:13:32 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7417
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:12:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7416
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:11:04 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7415
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:10:01 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7414
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Fri, 10 Jul 2026 00:04:21 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7413
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:02:27 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #7412
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 09 Jul 2026 13:03:28 -0400
Radu Rendec <[email protected]> • #7411
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 9 Jul 2026 17:26:59 +0100
David Laight <[email protected]> • #7410
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 09:23:47 -0700
Kees Cook <[email protected]> • #7409
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Thu, 9 Jul 2026 09:22:06 -0700
Kees Cook <[email protected]> • #7408
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:22:26 +0200
Philippe Mathieu-Daudé <[email protected]> • #7407
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:20:43 +0200
Philippe Mathieu-Daudé <[email protected]> • #7406
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:18:04 +0200
Philippe Mathieu-Daudé <[email protected]> • #7405
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:17:17 +0200
Philippe Mathieu-Daudé <[email protected]> • #7404
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:51 +0200
Philippe Mathieu-Daudé <[email protected]> • #7403
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:21 +0200
Philippe Mathieu-Daudé <[email protected]> • #7402
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:55 +0200
Philippe Mathieu-Daudé <[email protected]> • #7401
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:11 +0200
Philippe Mathieu-Daudé <[email protected]> • #7400
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 13:12:57 +0200
Philippe Mathieu-Daudé <[email protected]> • #7399
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 10:41:56 +0200
Geert Uytterhoeven <[email protected]> • #7398
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 11:46:07 +0800
Jinjie Ruan <[email protected]> • #7397
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 10:55:27 +0800
Jinjie Ruan <[email protected]> • #7396
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 9 Jul 2026 10:49:49 +0800
Jinjie Ruan <[email protected]> • #7395
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:46:44 +0800
Jinjie Ruan <[email protected]> • #7394
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:44:48 +0800
Jinjie Ruan <[email protected]> • #7393
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:39:17 +0800
Jinjie Ruan <[email protected]> • #7392
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:38:38 +0800
Jinjie Ruan <[email protected]> • #7391
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:38:16 +0800
Jinjie Ruan <[email protected]> • #7390
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:37:44 +0800
Jinjie Ruan <[email protected]> • #7389
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:34:22 +0800
Jinjie Ruan <[email protected]> • #7388
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 10:13:11 +0800
Jinjie Ruan <[email protected]> • #7387
Re: [patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Thu, 9 Jul 2026 10:03:49 +0800
Jinjie Ruan <[email protected]> • #7386
Re: [patch 15/18] x86/entry: Make syscall functions static
Thu, 9 Jul 2026 09:47:56 +0800
Jinjie Ruan <[email protected]> • #7385
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 09:41:18 +0800
Jinjie Ruan <[email protected]> • #7384
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 09:20:32 +0800
Jinjie Ruan <[email protected]> • #7383
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 09 Jul 2026 01:14:24 +0200
Thomas Gleixner <[email protected]> • #7382
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 09 Jul 2026 00:08:11 +0200
Thomas Gleixner <[email protected]> • #7381
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 23:49:57 +0200
Thomas Gleixner <[email protected]> • #7380
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Wed, 08 Jul 2026 17:39:50 -0400
Radu Rendec <[email protected]> • #7379
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Wed, 08 Jul 2026 17:21:19 -0400
Radu Rendec <[email protected]> • #7378
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:59:18 -0400
Radu Rendec <[email protected]> • #7377
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:51 -0400
Radu Rendec <[email protected]> • #7376
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:00 -0400
Radu Rendec <[email protected]> • #7375
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 08 Jul 2026 22:34:38 +0200
Thomas Gleixner <[email protected]> • #7374
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:37:13 -0400
Radu Rendec <[email protected]> • #7373
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:35:48 -0400
Radu Rendec <[email protected]> • #7372
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 13:26:19 -0400
Radu Rendec <[email protected]> • #7371
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Wed, 08 Jul 2026 13:24:33 -0400
Radu Rendec <[email protected]> • #7370
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 08 Jul 2026 13:22:58 -0400
Radu Rendec <[email protected]> • #7369
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 18:04:19 +0200
Oleg Nesterov <[email protected]> • #7368
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 8 Jul 2026 17:52:42 +0200
Michal Suchánek <[email protected]> • #7367
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Wed, 8 Jul 2026 17:46:24 +0200
Oleg Nesterov <[email protected]> • #7366
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 8 Jul 2026 19:37:51 +0530
Shrikanth Hegde <[email protected]> • #7365
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 08 Jul 2026 11:16:25 +0200
Thomas Gleixner <[email protected]> • #7364
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 11:15:10 +0200
Thomas Gleixner <[email protected]> • #7363
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 08:47:15 +0200
Sven Schnelle <[email protected]> • #7362
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 8 Jul 2026 10:51:56 +0530
Shrikanth Hegde <[email protected]> • #7361
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 09:43:46 +0800
Jinjie Ruan <[email protected]> • #7360
[patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Tue, 07 Jul 2026 21:07:09 +0200
Thomas Gleixner <[email protected]> • #7359
[patch 17/18] x86/entry: Simplify the syscall number logic
Tue, 07 Jul 2026 21:07:05 +0200
Thomas Gleixner <[email protected]> • #7358
[patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Tue, 07 Jul 2026 21:07:01 +0200
Thomas Gleixner <[email protected]> • #7357
[patch 15/18] x86/entry: Make syscall functions static
Tue, 07 Jul 2026 21:06:57 +0200
Thomas Gleixner <[email protected]> • #7356
[patch 14/18] entry: Make return type of syscall_trace_enter() bool
Tue, 07 Jul 2026 21:06:53 +0200
Thomas Gleixner <[email protected]> • #7355
[patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Tue, 07 Jul 2026 21:06:44 +0200
Thomas Gleixner <[email protected]> • #7354
[patch 13/18] entry: Make trace_syscall_enter() return type bool
Tue, 07 Jul 2026 21:06:48 +0200
Thomas Gleixner <[email protected]> • #7353
[patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Tue, 07 Jul 2026 21:06:40 +0200
Thomas Gleixner <[email protected]> • #7352
[patch 10/18] entry: Use syscall number instead of rereading it
Tue, 07 Jul 2026 21:06:36 +0200
Thomas Gleixner <[email protected]> • #7351
[patch 09/18] entry: Remove syscall_enter_from_user_mode()
Tue, 07 Jul 2026 21:06:32 +0200
Thomas Gleixner <[email protected]> • #7350
[patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:27 +0200
Thomas Gleixner <[email protected]> • #7349
[patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:23 +0200
Thomas Gleixner <[email protected]> • #7348
[patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:19 +0200
Thomas Gleixner <[email protected]> • #7347
[patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:15 +0200
Thomas Gleixner <[email protected]> • #7346
[patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:11 +0200
Thomas Gleixner <[email protected]> • #7345
[patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:07 +0200
Thomas Gleixner <[email protected]> • #7344
[patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Tue, 07 Jul 2026 21:06:02 +0200
Thomas Gleixner <[email protected]> • #7343
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.