org.kernel.vger.linux-sgx archive

371 archived articles, newest first (page 1 of 4). Latest articles →

Re: [PATCH] x86/sgx: Drop enclave reference on MMU notifier registration failure
Fri, 21 Aug 2026 04:15:08 +0300
Jarkko Sakkinen <[email protected]> • #10932
Re: [PATCH] x86/sgx: Drop enclave reference on MMU notifier registration failure
Thu, 20 Aug 2026 14:30:06 +0200
Markus Elfring <[email protected]> • #10931
Re: [PATCH] x86/sgx: Drop enclave reference on MMU notifier registration failure
Tue, 18 Aug 2026 11:27:57 +0000
"Huang, Kai" <[email protected]> • #10930
[PATCH] x86/sgx: Drop enclave reference on MMU notifier registration failure
Fri, 14 Aug 2026 21:40:20 +0800
Ruoyu Wang <[email protected]> • #10929
[PATCH v2 1/3] x86/sgx: Remove unused TCS definitions
Wed, 29 Jul 2026 14:56:26 +0200
Thorsten Blum <[email protected]> • #10928
[PATCH v2 3/3] x86/sgx: Use SGX_LAUNCH_TOKEN_SIZE in __sgx_virt_einit()
Wed, 29 Jul 2026 14:56:28 +0200
Thorsten Blum <[email protected]> • #10927
[PATCH v2 2/3] x86/sgx: Remove unused size and count definitions
Wed, 29 Jul 2026 14:56:27 +0200
Thorsten Blum <[email protected]> • #10926
[PATCH v2 0/3] x86/sgx: Remove unused definitions and reuse launch token size
Wed, 29 Jul 2026 14:56:25 +0200
Thorsten Blum <[email protected]> • #10925
Re: [PATCH v6] x86/sgx: Report RCU-Tasks quiescent state in EPC sanitization loop
Fri, 24 Jul 2026 10:07:28 +0300
Jarkko Sakkinen <[email protected]> • #10924
[PATCH v6] x86/sgx: Report RCU-Tasks quiescent state in EPC sanitization loop
Fri, 24 Jul 2026 10:55:14 +0800
Jun Miao <[email protected]> • #10923
Re: [PATCH v5] x86/sgx: Report RCU-Tasks quiescent state in EPC sanitization loop
Thu, 23 Jul 2026 16:03:52 +0300
Jarkko Sakkinen <[email protected]> • #10922
RE: [PATCH v5] x86/sgx: Report RCU-Tasks quiescent state in EPC sanitization loop
Thu, 23 Jul 2026 09:57:33 +0000
"Miao, Jun" <[email protected]> • #10921
Re: [PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
Wed, 22 Jul 2026 22:42:45 -0400
"Zi Yan" <[email protected]> • #10920
Re: [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Wed, 22 Jul 2026 22:40:28 -0400
"Zi Yan" <[email protected]> • #10919
Re: [PATCH] selftests/sgx: use MAP_FAILED for mmap error check
Wed, 22 Jul 2026 18:33:55 +0300
Jarkko Sakkinen <[email protected]> • #10918
Re: [PATCH] selftests/sgx: use MAP_FAILED for mmap error check
Wed, 22 Jul 2026 02:17:55 +0000
"Huang, Kai" <[email protected]> • #10917
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Mon, 20 Jul 2026 08:20:01 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #10916
[PATCH] selftests/sgx: use MAP_FAILED for mmap error check
Mon, 20 Jul 2026 10:54:43 +0800
longlong yan <[email protected]> • #10915
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Sun, 19 Jul 2026 19:27:23 -0400
"Liam R. Howlett" <[email protected]> • #10914
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Fri, 17 Jul 2026 22:59:11 -0400
"Zi Yan" <[email protected]> • #10913
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Fri, 17 Jul 2026 22:58:49 -0400
"Zi Yan" <[email protected]> • #10912
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Fri, 17 Jul 2026 22:57:58 -0400
"Zi Yan" <[email protected]> • #10911
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Fri, 17 Jul 2026 22:56:44 -0400
"Zi Yan" <[email protected]> • #10910
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Fri, 17 Jul 2026 22:54:24 -0400
"Zi Yan" <[email protected]> • #10909
Re: [PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
Fri, 17 Jul 2026 22:46:28 -0400
"Zi Yan" <[email protected]> • #10908
Re: [PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
Fri, 17 Jul 2026 22:46:01 -0400
"Zi Yan" <[email protected]> • #10907
Re: [PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
Fri, 17 Jul 2026 22:37:21 -0400
"Zi Yan" <[email protected]> • #10906
Re: [PATCH v2 04/33] mm: introduce and use vma_end_pgoff()
Fri, 17 Jul 2026 22:35:08 -0400
"Zi Yan" <[email protected]> • #10905
Re: [PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
Fri, 17 Jul 2026 22:32:47 -0400
"Zi Yan" <[email protected]> • #10904
Re: [PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
Fri, 17 Jul 2026 22:32:04 -0400
"Zi Yan" <[email protected]> • #10903
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Fri, 17 Jul 2026 22:29:09 -0400
"Zi Yan" <[email protected]> • #10902
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Thu, 16 Jul 2026 14:31:43 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #10901
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Thu, 16 Jul 2026 12:03:41 +0200
Christian König <[email protected]> • #10900
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Thu, 16 Jul 2026 10:46:34 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #10899
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Thu, 16 Jul 2026 10:44:14 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #10898
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Thu, 16 Jul 2026 11:43:35 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10897
Re: [PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
Thu, 16 Jul 2026 10:42:12 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #10896
Re: [PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Thu, 16 Jul 2026 10:36:05 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #10895
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Thu, 16 Jul 2026 10:33:51 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #10894
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Thu, 16 Jul 2026 10:27:33 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #10893
Re: [PATCH v2 31/33] mm/vma: use guard clauses in can_vma_merge_[before, after]()
Thu, 16 Jul 2026 10:39:54 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10892
Re: [PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
Thu, 16 Jul 2026 10:38:00 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10891
Re: [PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
Thu, 16 Jul 2026 10:28:37 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10890
Re: [PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
Thu, 16 Jul 2026 10:22:51 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10889
Re: [PATCH v2 27/33] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
Thu, 16 Jul 2026 10:20:50 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10888
Re: [PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
Thu, 16 Jul 2026 09:47:05 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10887
Re: [PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
Wed, 15 Jul 2026 15:53:23 -0400
"Liam R. Howlett" <[email protected]> • #10886
Re: [PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
Wed, 15 Jul 2026 15:51:01 -0400
"Liam R. Howlett" <[email protected]> • #10885
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Wed, 15 Jul 2026 14:05:42 -0400
"Liam R. Howlett" <[email protected]> • #10884
Re: [PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Wed, 15 Jul 2026 19:45:59 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10883
Re: [PATCH v2 24/33] mm/vma: move __install_special_mapping() to vma.c
Wed, 15 Jul 2026 19:39:53 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10882
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Wed, 15 Jul 2026 19:38:38 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10881
Re: [PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
Wed, 15 Jul 2026 19:33:00 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10880
Re: [PATCH v2 21/33] mm: use linear_page_[index, delta]() consistently
Wed, 15 Jul 2026 19:30:34 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10879
Re: [PATCH v2 20/33] mm/vma: remove duplicative vma_pgoff_offset() helper
Wed, 15 Jul 2026 19:28:00 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10878
Re: [PATCH v2 19/33] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Wed, 15 Jul 2026 18:44:49 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10877
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Wed, 15 Jul 2026 17:23:09 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10876
Re: [PATCH v2 17/33] mm: introduce and use linear_page_delta()
Wed, 15 Jul 2026 16:57:29 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10875
Re: [PATCH v2 16/33] mm/vma: minor cleanup of expand_[upwards, downwards]()
Wed, 15 Jul 2026 16:53:57 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10874
Re: [PATCH v2 15/33] mm/vma: refactor vmg_adjust_set_range() for clarity
Wed, 15 Jul 2026 16:49:21 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10873
Re: [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Tue, 14 Jul 2026 11:17:11 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #10872
Re: [PATCH 2/3] x86/sgx: Remove unused size and count definitions
Tue, 14 Jul 2026 00:24:38 +0000
"Huang, Kai" <[email protected]> • #10871
Re: [PATCH 1/3] x86/sgx: Remove unused TCS definitions
Tue, 14 Jul 2026 00:23:21 +0000
"Huang, Kai" <[email protected]> • #10870
Re: [PATCH 3/3] x86/sgx: Use SGX_LAUNCH_TOKEN_SIZE in __sgx_virt_einit()
Tue, 14 Jul 2026 00:21:59 +0000
"Huang, Kai" <[email protected]> • #10869
Re: [PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
Mon, 13 Jul 2026 20:18:54 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10868
Re: [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Mon, 13 Jul 2026 20:12:24 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10867
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Mon, 13 Jul 2026 20:07:25 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10866
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Mon, 13 Jul 2026 20:06:19 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10865
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Mon, 13 Jul 2026 20:05:19 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10864
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Mon, 13 Jul 2026 20:04:07 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10863
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Mon, 13 Jul 2026 20:03:02 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10862
Re: [PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
Mon, 13 Jul 2026 19:59:21 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10861
Re: [PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
Mon, 13 Jul 2026 19:56:52 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10860
Re: [PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
Mon, 13 Jul 2026 19:48:18 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #10859
Re: [PATCH 3/3] x86/sgx: Use SGX_LAUNCH_TOKEN_SIZE in __sgx_virt_einit()
Sat, 11 Jul 2026 21:23:11 +0300
Jarkko Sakkinen <[email protected]> • #10858
Re: [PATCH 2/3] x86/sgx: Remove unused size and count definitions
Sat, 11 Jul 2026 21:22:23 +0300
Jarkko Sakkinen <[email protected]> • #10857
Re: [PATCH 1/3] x86/sgx: Remove unused TCS definitions
Sat, 11 Jul 2026 21:22:01 +0300
Jarkko Sakkinen <[email protected]> • #10856
[PATCH 0/3] x86/sgx: Remove unused definitions and reuse launch token size
Sat, 11 Jul 2026 12:00:54 +0200
Thorsten Blum <[email protected]> • #10855
[PATCH 3/3] x86/sgx: Use SGX_LAUNCH_TOKEN_SIZE in __sgx_virt_einit()
Sat, 11 Jul 2026 12:00:57 +0200
Thorsten Blum <[email protected]> • #10854
[PATCH 2/3] x86/sgx: Remove unused size and count definitions
Sat, 11 Jul 2026 12:00:56 +0200
Thorsten Blum <[email protected]> • #10853
[PATCH 1/3] x86/sgx: Remove unused TCS definitions
Sat, 11 Jul 2026 12:00:55 +0200
Thorsten Blum <[email protected]> • #10852
Re: [PATCH v2 32/33] tools/testing/vma: default VMA, mm flag bits to 64-bit
Sat, 11 Jul 2026 07:34:36 +0100
Lorenzo Stoakes <[email protected]> • #10851
Re: [PATCH v2 33/33] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
Sat, 11 Jul 2026 07:32:51 +0100
Lorenzo Stoakes <[email protected]> • #10850
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Sat, 11 Jul 2026 07:29:47 +0100
Lorenzo Stoakes <[email protected]> • #10849
Re: [PATCH 30/30] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
Sat, 11 Jul 2026 07:26:27 +0100
Lorenzo Stoakes <[email protected]> • #10848
Re: [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
Sat, 11 Jul 2026 07:21:43 +0100
Lorenzo Stoakes <[email protected]> • #10847
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Fri, 10 Jul 2026 15:45:21 -0700
Andrew Morton <[email protected]> • #10846
Re: [PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
Fri, 10 Jul 2026 17:39:19 -0400
Gregory Price <[email protected]> • #10845
Re: [PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
Fri, 10 Jul 2026 17:26:59 -0400
Gregory Price <[email protected]> • #10844
Re: [PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
Fri, 10 Jul 2026 17:24:03 -0400
Gregory Price <[email protected]> • #10843
Re: [PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
Fri, 10 Jul 2026 17:20:56 -0400
Gregory Price <[email protected]> • #10842
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Fri, 10 Jul 2026 17:17:45 -0400
Gregory Price <[email protected]> • #10841
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Fri, 10 Jul 2026 17:16:51 -0400
Gregory Price <[email protected]> • #10840
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Fri, 10 Jul 2026 17:14:03 -0400
Gregory Price <[email protected]> • #10839
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Fri, 10 Jul 2026 17:12:07 -0400
Gregory Price <[email protected]> • #10838
Re: [PATCH v2 33/33] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
Fri, 10 Jul 2026 17:09:54 -0400
Gregory Price <[email protected]> • #10837
Re: [PATCH v2 32/33] tools/testing/vma: default VMA, mm flag bits to 64-bit
Fri, 10 Jul 2026 17:08:30 -0400
Gregory Price <[email protected]> • #10836
Re: [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
Fri, 10 Jul 2026 17:03:58 -0400
Gregory Price <[email protected]> • #10835
Re: [PATCH 30/30] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
Fri, 10 Jul 2026 16:48:58 -0400
Gregory Price <[email protected]> • #10834
[PATCH v2 33/33] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
Fri, 10 Jul 2026 21:17:14 +0100
Lorenzo Stoakes <[email protected]> • #10833
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.