org.kernel.vger.rust-for-linux archive

1314 archived articles, newest first (page 1 of 14). Latest articles →

Re: [PATCH v4 3/7] drm: nova: Add chipid enum to nova-drm UAPI
Mon, 24 Aug 2026 21:24:07 +0200
"Danilo Krummrich" <[email protected]> • #51334
Re: [PATCH v4 4/7] drm: nova: Add a GPU info ioctl
Mon, 24 Aug 2026 21:10:04 +0200
"Danilo Krummrich" <[email protected]> • #51333
Re: [PATCH 1/2] drm/tyr: move reset work to platform driver data
Mon, 24 Aug 2026 14:27:23 -0300
Daniel Almeida <[email protected]> • #51332
Re: [PATCH v6 3/3] drm/tyr: put iomem behind the hardware gate
Mon, 24 Aug 2026 14:05:11 -0300
Daniel Almeida <[email protected]> • #51331
Re: [PATCH v8 1/1] rust: pci: add extended capability and SR-IOV support
Mon, 24 Aug 2026 17:25:04 +0100
"Gary Guo" <[email protected]> • #51330
Re: [PATCH v8 1/1] rust: pci: add extended capability and SR-IOV support
Mon, 24 Aug 2026 16:46:29 +0100
"Gary Guo" <[email protected]> • #51329
Re: [PATCH v4] rust: num: restrict bool conversion to unsigned Bounded
Tue, 25 Aug 2026 00:27:44 +0900
"Alexandre Courbot" <[email protected]> • #51328
Re: [PATCH v8 1/1] rust: pci: add extended capability and SR-IOV support
Tue, 25 Aug 2026 00:21:55 +0900
"Alexandre Courbot" <[email protected]> • #51327
Re: [PATCH v4 3/7] drm: nova: Add chipid enum to nova-drm UAPI
Mon, 24 Aug 2026 10:49:36 -0400
M Henning <[email protected]> • #51326
Re: [PATCH v19 00/40] DEPT(DEPendency Tracker)
Mon, 24 Aug 2026 16:12:29 +0200
"David Hildenbrand (Arm)" <[email protected]> • #51325
[PATCH v2 2/2] kunit: add KUnit test to assert kernel state before KUnit suites are run
Mon, 24 Aug 2026 15:32:31 +0200
Malte Wechter <[email protected]> • #51324
[PATCH v2 1/2] kunit: add extra assertions to KUnit test cases
Mon, 24 Aug 2026 15:32:30 +0200
Malte Wechter <[email protected]> • #51323
[PATCH v2 0/2] kunit: add optional assertions to catch taint and lockdep warnings
Mon, 24 Aug 2026 15:32:29 +0200
Malte Wechter <[email protected]> • #51322
[PATCH v2 11/13] drm/panic: Internalize panic locking in DRM core and helpers
Mon, 24 Aug 2026 14:43:42 +0200
Thomas Zimmermann <[email protected]> • #51321
[PATCH v2 06/13] drm/panic: Pass global module parameters to drm_panic_dispatch()
Mon, 24 Aug 2026 14:43:37 +0200
Thomas Zimmermann <[email protected]> • #51320
Re: [PATCH 2/6] gpu: nova-core: add NVKV encoder
Mon, 24 Aug 2026 21:58:35 +0900
"Eliot Courtney" <[email protected]> • #51319
[PATCH v2 07/13] drm/panic: Retry in dispatch function if panic output fails
Mon, 24 Aug 2026 14:43:38 +0200
Thomas Zimmermann <[email protected]> • #51318
[PATCH v2 05/13] drm/panic: Pass colors to draw_panic_dispatch()
Mon, 24 Aug 2026 14:43:36 +0200
Thomas Zimmermann <[email protected]> • #51317
[PATCH v2 00/13] drm/panic: Split into core and helpers
Mon, 24 Aug 2026 14:43:31 +0200
Thomas Zimmermann <[email protected]> • #51316
[PATCH v2 13/13] drm/panic: Compile KUnit tests as module
Mon, 24 Aug 2026 14:43:44 +0200
Thomas Zimmermann <[email protected]> • #51315
[PATCH v2 10/13] drm/panic: Display panic screen via per-plane callback
Mon, 24 Aug 2026 14:43:41 +0200
Thomas Zimmermann <[email protected]> • #51314
[PATCH v2 04/13] drm/panic: Return errno codes if panic output fails
Mon, 24 Aug 2026 14:43:35 +0200
Thomas Zimmermann <[email protected]> • #51313
[PATCH v2 03/13] drm/panic: Return -EINVAL if font is not available
Mon, 24 Aug 2026 14:43:34 +0200
Thomas Zimmermann <[email protected]> • #51312
[PATCH v2 02/13] drm/panic: Test address from kmap op for NULL
Mon, 24 Aug 2026 14:43:33 +0200
Thomas Zimmermann <[email protected]> • #51311
[PATCH v2 01/13] drm/panic: Do not use un-escaped URL as format string
Mon, 24 Aug 2026 14:43:32 +0200
Thomas Zimmermann <[email protected]> • #51310
[PATCH v2 12/13] drm/panic: Move panic display code into helper library
Mon, 24 Aug 2026 14:43:43 +0200
Thomas Zimmermann <[email protected]> • #51309
[PATCH v2 09/13] drm/panic: Restrict to primary planes; unconditionally unregister
Mon, 24 Aug 2026 14:43:40 +0200
Thomas Zimmermann <[email protected]> • #51308
[PATCH v2 08/13] drm/panic: Split draw_panic_plane()
Mon, 24 Aug 2026 14:43:39 +0200
Thomas Zimmermann <[email protected]> • #51307
Re: [PATCH v20 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
Mon, 24 Aug 2026 14:26:11 +0200
Uwe Kleine-König <[email protected]> • #51306
Re: [PATCH v7 02/10] rust: bitmap: restrict bitmap length to at most i32::MAX
Mon, 24 Aug 2026 21:04:03 +0900
"Eliot Courtney" <[email protected]> • #51305
Re: [PATCH v8 1/1] rust: pci: add extended capability and SR-IOV support
Mon, 24 Aug 2026 12:59:20 +0100
"Gary Guo" <[email protected]> • #51304
RE: [PATCH net v2] rust: net: phy: fix off-by-one bit positions in device status accessors
Mon, 24 Aug 2026 19:47:33 +0800
<[email protected]> • #51303
Re: [GIT PULL] rust-i2c-next for 7.3
Mon, 24 Aug 2026 13:45:53 +0200
Andi Shyti <[email protected]> • #51302
Re: [PATCH net v2] rust: net: phy: fix off-by-one bit positions in device status accessors
Mon, 24 Aug 2026 13:39:10 +0200
Miguel Ojeda <[email protected]> • #51301
Re: [PATCH v8 1/1] rust: pci: add extended capability and SR-IOV support
Mon, 24 Aug 2026 13:38:05 +0200
"Danilo Krummrich" <[email protected]> • #51300
Re: [PATCH v20 6/8] rust: Add missing SAFETY documentation for `ARef` example
Mon, 24 Aug 2026 13:36:22 +0200
Miguel Ojeda <[email protected]> • #51299
Re: [PATCH v4] rust: num: restrict bool conversion to unsigned Bounded
Mon, 24 Aug 2026 13:32:50 +0200
Miguel Ojeda <[email protected]> • #51298
[PATCH v20 8/8] rust: page: add `from_raw()`
Mon, 24 Aug 2026 13:18:00 +0200
Andreas Hindborg <[email protected]> • #51297
[PATCH v20 4/8] rust: page: convert to `Ownable`
Mon, 24 Aug 2026 13:17:56 +0200
Andreas Hindborg <[email protected]> • #51296
[PATCH v20 2/8] rust: types: Add Ownable/Owned types
Mon, 24 Aug 2026 13:17:54 +0200
Andreas Hindborg <[email protected]> • #51295
[PATCH v20 6/8] rust: Add missing SAFETY documentation for `ARef` example
Mon, 24 Aug 2026 13:17:58 +0200
Andreas Hindborg <[email protected]> • #51294
[PATCH v20 3/8] rust: implement `ForeignOwnable` for `Owned`
Mon, 24 Aug 2026 13:17:55 +0200
Andreas Hindborg <[email protected]> • #51293
[PATCH v20 1/8] rust: alloc: add `KBox::into_non_null`
Mon, 24 Aug 2026 13:17:53 +0200
Andreas Hindborg <[email protected]> • #51292
[PATCH v20 7/8] rust: Add `OwnableRefCounted`
Mon, 24 Aug 2026 13:17:59 +0200
Andreas Hindborg <[email protected]> • #51291
[PATCH v20 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
Mon, 24 Aug 2026 13:17:57 +0200
Andreas Hindborg <[email protected]> • #51290
[PATCH v20 0/8] rust: add `Ownable` trait and `Owned` type
Mon, 24 Aug 2026 13:17:52 +0200
Andreas Hindborg <[email protected]> • #51289
Re: [PATCH v8 1/1] rust: pci: add extended capability and SR-IOV support
Mon, 24 Aug 2026 20:14:01 +0900
"Alexandre Courbot" <[email protected]> • #51288
[PATCH net v2] rust: net: phy: fix off-by-one bit positions in device status accessors
Mon, 24 Aug 2026 11:12:27 +0000
Chunfeng Song <[email protected]> • #51287
Re: [PATCH 0/4] Fix forward()/expires() racing with concurrent arming
Mon, 24 Aug 2026 20:07:25 +0900 (JST)
FUJITA Tomonori <[email protected]> • #51286
Re: [PATCH v8 1/1] rust: introduce abstractions for fwctl
Mon, 24 Aug 2026 12:06:12 +0100
"Gary Guo" <[email protected]> • #51285
Re: [PATCH 0/4] Fix forward()/expires() racing with concurrent arming
Mon, 24 Aug 2026 12:59:20 +0200
Miguel Ojeda <[email protected]> • #51284
Re: [PATCH v8 1/1] rust: pci: add extended capability and SR-IOV support
Mon, 24 Aug 2026 11:48:50 +0100
"Gary Guo" <[email protected]> • #51283
Re: [PATCH 0/4] Fix forward()/expires() racing with concurrent arming
Mon, 24 Aug 2026 12:44:44 +0200
Andreas Hindborg <[email protected]> • #51282
Re: [PATCH 1/2] kbuild: rust: preserve unreachable traps with inline helpers
Mon, 24 Aug 2026 12:39:16 +0200
Miguel Ojeda <[email protected]> • #51281
Re: [PATCH 1/2] kbuild: rust: preserve unreachable traps with inline helpers
Mon, 24 Aug 2026 12:38:52 +0200
Miguel Ojeda <[email protected]> • #51280
Re: [PATCH 2/2] kbuild: rust: keep Rust objects out of Clang LTO with inline helpers
Mon, 24 Aug 2026 12:33:42 +0200
Miguel Ojeda <[email protected]> • #51279
Re: [RFC PATCH v5 3/3] iio: position: add Rust driver for ams AS5600
Mon, 24 Aug 2026 01:17:49 +0100
Jonathan Cameron <[email protected]> • #51269
Re: [PATCH] rust: net: phy: fix off-by-one bit positions in device status accessors
Mon, 24 Aug 2026 09:11:42 +0900 (JST)
FUJITA Tomonori <[email protected]> • #51268
Re: [RFC PATCH v5 2/3] rust: add minimal IIO subsystem abstractions
Mon, 24 Aug 2026 01:07:26 +0100
Jonathan Cameron <[email protected]> • #51267
Re: [RFC PATCH v5 1/3] i2c: rust: implement SMBus access via IoBackend and FallibleIoCapable
Mon, 24 Aug 2026 00:41:03 +0100
Jonathan Cameron <[email protected]> • #51266
Re: [PATCH] rust: kbuild: disambiguate `zerocopy_derive` for `rusttest`
Sun, 23 Aug 2026 21:56:49 +0200
Miguel Ojeda <[email protected]> • #51265
[PATCH] rust: kbuild: disambiguate `zerocopy_derive` for `rusttest`
Sun, 23 Aug 2026 21:35:29 +0200
Miguel Ojeda <[email protected]> • #51264
RE: [PATCH] rust: net: phy: fix off-by-one bit positions in device status accessors
Sun, 23 Aug 2026 23:51:16 +0800
<[email protected]> • #51263
Re: [PATCH] rust: net: phy: fix off-by-one bit positions in device status accessors
Sun, 23 Aug 2026 17:27:20 +0200
Andrew Lunn <[email protected]> • #51262
Re: [PATCH] rust: net: phy: fix off-by-one bit positions in device status accessors
Sun, 23 Aug 2026 13:40:32 +0200
Miguel Ojeda <[email protected]> • #51261
[PATCH 2/2] drm/tyr: unplug the GPU when reset fails
Sun, 23 Aug 2026 13:50:08 +0300
Onur Özkan <[email protected]> • #51260
[PATCH 1/2] drm/tyr: move reset work to platform driver data
Sun, 23 Aug 2026 13:50:07 +0300
Onur Özkan <[email protected]> • #51259
[PATCH 0/2] drm/tyr: unplug the GPU when reset fails
Sun, 23 Aug 2026 13:50:06 +0300
Onur Özkan <[email protected]> • #51258
Re: [PATCH] rust: net: phy: fix off-by-one bit positions in device status accessors
Sun, 23 Aug 2026 12:50:39 +0200
Miguel Ojeda <[email protected]> • #51257
[PATCH] rust: net: phy: fix off-by-one bit positions in device status accessors
Sun, 23 Aug 2026 10:36:44 +0000
Chunfeng Song <[email protected]> • #51256
Re: [PATCH v23 06/28] riscv/mm : ensure PROT_WRITE leads to VM_READ | VM_WRITE
Sat, 22 Aug 2026 18:50:22 +0200
Andreas Schwab <[email protected]> • #51255
Re: [GIT PULL] rust-i2c-next for 7.3
Sat, 22 Aug 2026 14:24:50 +0200
Andi Shyti <[email protected]> • #51254
Re: [GIT PULL] rust-i2c-next for 7.3
Sat, 22 Aug 2026 12:38:47 +0100
Igor Korotin <[email protected]> • #51253
[PATCH v4] rust: num: restrict bool conversion to unsigned Bounded
Sat, 22 Aug 2026 10:44:47 +0200
Younes Akhouayri via B4 Relay <[email protected]> • #51252
[RFC PATCH v5 3/3] iio: position: add Rust driver for ams AS5600
Sat, 22 Aug 2026 14:26:58 +0800
Muchamad Coirul Anwar <[email protected]> • #51251
[RFC PATCH v5 2/3] rust: add minimal IIO subsystem abstractions
Sat, 22 Aug 2026 14:26:57 +0800
Muchamad Coirul Anwar <[email protected]> • #51250
[RFC PATCH v5 1/3] i2c: rust: implement SMBus access via IoBackend and FallibleIoCapable
Sat, 22 Aug 2026 14:26:56 +0800
Muchamad Coirul Anwar <[email protected]> • #51249
[RFC PATCH v5 0/3] iio: position: add Rust driver for ams AS5600
Sat, 22 Aug 2026 14:26:55 +0800
Muchamad Coirul Anwar <[email protected]> • #51248
Re: [PATCH RESEND v3] hardening: Default randstruct off with rust for better allmodconfig support
Fri, 21 Aug 2026 21:48:35 +0200
Miguel Ojeda <[email protected]> • #51247
Re: [PATCH v7 05/10] rust: bitmap: add contiguous area operations
Fri, 21 Aug 2026 21:35:31 +0200
Miguel Ojeda <[email protected]> • #51246
Re: [PATCH v6 2/3] drm/tyr: add GPU reset infrastructure
Fri, 21 Aug 2026 20:53:41 +0200
"Danilo Krummrich" <[email protected]> • #51245
Re: [PATCH RESEND v3] hardening: Default randstruct off with rust for better allmodconfig support
Fri, 21 Aug 2026 10:36:25 -0700
Kees Cook <[email protected]> • #51244
Re: [PATCH v6 2/3] drm/tyr: add GPU reset infrastructure
Fri, 21 Aug 2026 14:23:12 -0300
Daniel Almeida <[email protected]> • #51243
Re: [PATCH 7/7] dt-bindings: beagle: Add BeagleConnect Freedom
Fri, 21 Aug 2026 18:20:58 +0100
Conor Dooley <[email protected]> • #51242
Re: [PATCH v6 2/3] drm/tyr: add GPU reset infrastructure
Fri, 21 Aug 2026 19:01:10 +0200
"Danilo Krummrich" <[email protected]> • #51241
Re: [PATCH -next] rust: fwctl: replace `__pinned_init` with `raw_try_init`
Fri, 21 Aug 2026 18:56:05 +0200
Miguel Ojeda <[email protected]> • #51240
Re: [PATCH v6 2/3] drm/tyr: add GPU reset infrastructure
Fri, 21 Aug 2026 19:42:30 +0300
Onur Özkan <[email protected]> • #51239
Re: [PATCH v6 2/3] drm/tyr: add GPU reset infrastructure
Fri, 21 Aug 2026 13:39:45 -0300
Daniel Almeida <[email protected]> • #51238
Re: [PATCH v6 2/3] drm/tyr: add GPU reset infrastructure
Fri, 21 Aug 2026 18:12:23 +0200
"Danilo Krummrich" <[email protected]> • #51237
Re: [PATCH v6 2/3] drm/tyr: add GPU reset infrastructure
Fri, 21 Aug 2026 18:58:12 +0300
Onur Özkan <[email protected]> • #51236
Re: [PATCH v6 2/3] drm/tyr: add GPU reset infrastructure
Fri, 21 Aug 2026 12:31:03 -0300
Daniel Almeida <[email protected]> • #51235
Re: [PATCH v2 01/12] rust: num: use const_assert! in Bounded
Fri, 21 Aug 2026 23:01:30 +0900
"Alexandre Courbot" <[email protected]> • #51234
Re: [PATCH v2 01/12] rust: num: use const_assert! in Bounded
Fri, 21 Aug 2026 22:53:56 +0900
"Alexandre Courbot" <[email protected]> • #51233
Re: [PATCH v3] rust: num: restrict bool conversion to unsigned Bounded
Fri, 21 Aug 2026 21:02:45 +0900
"Alexandre Courbot" <[email protected]> • #51232
Re: [PATCH v7 10/10] rust: use Alignment size constants
Fri, 21 Aug 2026 20:04:34 +0900
"Alexandre Courbot" <[email protected]> • #51231
Re: [PATCH v7 05/10] rust: bitmap: add contiguous area operations
Fri, 21 Aug 2026 20:04:27 +0900
"Alexandre Courbot" <[email protected]> • #51230
Re: [PATCH 0/2] rust: kunit: add optional assertions to catch taint and lockdep warnings
Fri, 21 Aug 2026 12:18:02 +0200
Malte Wechter <[email protected]> • #51229
Re: [PATCH 0/4] Fix forward()/expires() racing with concurrent arming
Fri, 21 Aug 2026 18:53:08 +0900 (JST)
FUJITA Tomonori <[email protected]> • #51228
Re: [PATCH v19 00/40] DEPT(DEPendency Tracker)
Fri, 21 Aug 2026 19:48:40 +1000
NeilBrown <[email protected]> • #51227
Re: [PATCH] rust: cfi: disable function merging if CFI is enabled
Fri, 21 Aug 2026 11:20:18 +0200
Miguel Ojeda <[email protected]> • #51226
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.