[Accel-config] Re: [PATCH v2 0/7] Separate common codes from DSA source code file

Dave Jiang <dave.jiang at intel.com> Fri, 01 Apr 2022 10:53:56 -0700
Newsgroups dev.linux.lists.accel-config
Message-ID <[email protected]>
On 4/1/2022 5:55 AM, Li Zhang wrote:
> For sharing codes between DSA and IAA test code, move all
> reused code into common files, merge structs, rename symbols
> for universal meaning.
>
> Changelog:
> v2:
> - Change the prefix actst_ to acctest_
> - For avoiding using macro to conditionally compile DSA and IAA source
>    code, merge DSA and IAA structs.
>
> Reviewed-by: Dave Jiang <dave.jiang(a)intel.com>

I have not given my reviewed by tag yet.


>
> Li Zhang (7):
>    accel-config/test: DSA functions are renamed universal name
>    accel-config/test: Macros are renamed universal name
>    accel-config/test: Modify structs for reused by DSA and IAA
>    accel-config/test: Modify name of structs for universal meaning
>    accel-config/test: Create new files for placing reused code
>    accel-config/test: Rename prep.c to dsa_prep.c
>    accel-config/test: Move common code into common files
>
>   accfg/idxd.h                | 104 +++--
>   test/Makefile.am            |   2 +-
>   test/accel_test.c           | 514 +++++++++++++++++++++
>   test/accel_test.h           | 239 ++++++++++
>   test/dsa.c                  | 874 +++++++++---------------------------
>   test/dsa.h                  | 295 ++----------
>   test/{prep.c => dsa_prep.c} | 305 ++++++-------
>   test/dsa_test.c             | 181 ++++----
>   8 files changed, 1290 insertions(+), 1224 deletions(-)
>   create mode 100644 test/accel_test.c
>   create mode 100644 test/accel_test.h
>   rename test/{prep.c => dsa_prep.c} (68%)
>