Re: [PATCH 1/6] mm: rename VMA flag helpers to be more readable
"Lorenzo Stoakes (Oracle)" <[email protected]>
| Newsgroups | dev.linux.lists.ntfs3,dev.linux.lists.nvdimm,org.kernel.vger.linux-cxl,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel,org.kvack.linux-mm,org.ozlabs.lists.linux-erofs |
|---|---|
| Message-ID | <[email protected]> |
On Wed, Mar 25, 2026 at 02:51:04PM +0000, Pedro Falcato wrote: > On Thu, Mar 05, 2026 at 10:50:14AM +0000, Lorenzo Stoakes (Oracle) wrote: > > On reflection, it's confusing to have vma_flags_test() and > > vma_desc_test_flags() test whether any comma-separated VMA flag bit is set, > > while also having vma_flags_test_all() and vma_test_all_flags() separately > > test whether all flags are set. > > > > Firstly, rename vma_flags_test() to vma_flags_test_any() to eliminate this > > confusion. > > Hmm. The names are getting longer. We should fix this One Day. :) yeha it's a bit of a trade-off still. But for now keeping it (fairly) straightforward. > > > > > Secondly, since the VMA descriptor flag functions are becoming rather > > cumbersome, prefer vma_desc_test*() to vma_desc_test_flags*(), and also > > rename vma_desc_test_flags() to vma_desc_test_any(). > > > > > Finally, rename vma_test_all_flags() to vma_test_all() to keep the > > VMA-specific helper consistent with the VMA descriptor naming convention > > and to help avoid confusion vs. vma_flags_test_all(). > > > > While we're here, also update whitespace to be consistent in helper > > functions. > > Extremely amazing patch! you were truly inspired! > > > > Suggested-by: Pedro Falcato <[email protected]> > > Signed-off-by: Lorenzo Stoakes (Oracle) <[email protected]> > > Reviewed-by: Pedro Falcato <[email protected]> :) thanks, I don't know who could have suggested such an amazing idea, well I won't read the tags to check + spoil the surprise... :>) > > -- > Pedro Cheers, Lorenzo