Re: [PATCH 3/6] mm: always inline __mk_vma_flags() and invoked functions
Pedro Falcato <[email protected]>
| Newsgroups | dev.linux.lists.ntfs3,dev.linux.lists.nvdimm,org.kernel.vger.linux-cxl,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel,org.kvack.linux-mm,org.ozlabs.lists.linux-erofs |
|---|---|
| Message-ID | <ndtnvnobevdymu5a5tdxdbi4tcsqshs3d6x2vnfgnuclxvgwok@bhbqkzilsets> |
On Thu, Mar 05, 2026 at 10:50:16AM +0000, Lorenzo Stoakes (Oracle) wrote: > Be explicit about __mk_vma_flags() (which is used by the mk_vma_flags() > macro) always being inline, as we rely on the compiler converting this > function into meaningful. meaningful what? > > Also update all of the functions __mk_vma_flags() ultimately invokes to be > always inline too. > > Note that test_bitmap_const_eval() asserts that the relevant bitmap > functions result in build time constant values. > > Additionally, vma_flag_set() operates on a vma_flags_t type, so it is > inconsistently named versus other VMA flags functions. > > We only use vma_flag_set() in __mk_vma_flags() so we don't need to worry > about its new name being rather cumbersome, so rename it to > vma_flags_set_flag() to disambiguate it from vma_flags_set(). > > Also update the VMA test headers to reflect the changes. > > Signed-off-by: Lorenzo Stoakes (Oracle) <[email protected]> Reviewed-by: Pedro Falcato <[email protected]> Is there an actual difference in codegen here? On -O2. -- Pedro