Re: [PATCH 3/9] ACPI: pci: drop unused assignment of acpi_device_id::driver_data
[email protected] Mon, 27 Jul 2026 12:16:01 +0000
| Newsgroups | dev.linux.lists.nvdimm,org.kernel.vger.linux-pci |
|---|---|
| Message-ID | <[email protected]> |
> These modules set the acpi_device_id::driver_data to 0 but > the field is not actually used within the module, we can > just drop it from the table. > > While we are at it - used a named initializer for the > acpi_device_id::id field to increase readability and > drop explicitly setting the list terminator fields. > > Signed-off-by: Pawel Zalewski (The Capable Hub) <[email protected]> Sashiko has reviewed this patch and found no issues. It looks great! -- Sashiko AI review ยท https://sashiko.dev/#/patchset/[email protected]?part=3