Re: [PATCH 7/9] ACPI: nfit: core: drop unused assignment of acpi_device_id::driver_data
Dave Jiang <[email protected]> Mon, 27 Jul 2026 10:25:21 -0700
| Newsgroups | dev.linux.lists.nvdimm,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-acpi,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pci |
|---|---|
| Message-ID | <[email protected]> |
On 7/27/26 5:10 AM, Pawel Zalewski (The Capable Hub) wrote: > This module sets the acpi_device_id::driver_data to 0 but > the field is not actually used within the module, we can > just drop it from the table. > > While we are at it - used a named initializer for the > acpi_device_id::id field to increase readability and > drop explicitly setting the list terminator fields. > > Signed-off-by: Pawel Zalewski (The Capable Hub) <[email protected]> Reviewed-by: Dave Jiang <[email protected]> > --- > drivers/acpi/nfit/core.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/acpi/nfit/core.c b/drivers/acpi/nfit/core.c > index cb771d9cadb2..5732df5d53f0 100644 > --- a/drivers/acpi/nfit/core.c > +++ b/drivers/acpi/nfit/core.c > @@ -3515,8 +3515,8 @@ void __acpi_nfit_notify(struct device *dev, acpi_handle handle, u32 event) > EXPORT_SYMBOL_GPL(__acpi_nfit_notify); > > static const struct acpi_device_id acpi_nfit_ids[] = { > - { "ACPI0012", 0 }, > - { "", 0 }, > + { .id = "ACPI0012" }, > + { } > }; > MODULE_DEVICE_TABLE(acpi, acpi_nfit_ids); > >