Re: [PATCH v1 1/1] hte: Use kasprintf() instead of fixed buffer formatting

Dipen Patel <[email protected]> Fri, 27 Oct 2023 14:03:57 -0700
Newsgroups dev.linux.lists.timestamp,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
On 10/27/23 5:39 AM, Andy Shevchenko wrote:
> On Tue, Oct 10, 2023 at 09:12:09AM -0700, Dipen Patel wrote:
>> On 10/10/23 7:11 AM, Andy Shevchenko wrote:
>>> Improve readability and maintainability by replacing a hardcoded string
>>> allocation and formatting by the use of the kasprintf() helper.
> 
> ...
> 
>>>  	hte_ts_dbgfs_init(desc->attr.name == NULL ?
>>>  			  ei->line_name : desc->attr.name, ei);
>> Reviewed-by: Dipen Patel <[email protected]>
> 
> Thanks!
> 
> Who is the maintainer of this code?
> If not you, shouldn't MAINTAINERS to be updated to reflect that?
> 
I am the maintainer, I am not sure how did I miss this patch for my for-next.
Let me push this right away.