Re: [PATCH v2 2/2] x86/cpuid: Update bitfields to x86-cpuid-db v3.1

Ingo Molnar <[email protected]> Thu, 4 Jun 2026 09:41:24 +0200
Newsgroups dev.linux.lists.x86-cpuid,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
* Maciej Wieczor-Retman <[email protected]> wrote:

> From: Maciej Wieczor-Retman <[email protected]>
> 
> Update leaf_types.h to version 3.1, as generated by x86-cpuid-db.
> 
> Summary of the v3.1 changes:
> 
> * Fix a few typos that were found during the kernel CPUID data model
>   review. Also include fixes found using an LLM agent review.
> 
> * Rename thrd_director_nclasses to hw_feedback_nclasses as it's the
>   name used in Intel SDM.

The following detail from the first submission got lost:

> @@ -246,7 +246,7 @@ struct leaf_0x6_0 {
> -		thrd_director_nclasses		:  8, // Number of classes, Intel thread director
> +		hw_feedback_nclasses		:  8, // Number of Intel Thread Director classes
>
> Note, for CPUID(0x6) thrd_director_nclasses, it was written this way
> because the project does not support bitfields names with more letters.

What does this mean exactly, is there a string length limit on the
field name in 'struct leaf_0x6_0'? What is the limit?

Thanks,

	Ingo