Re: [PATCH 3/3] arm64: dts: amlogic: a9: Add reset controller support
| Newsgroups | org.infradead.lists.linux-amlogic,org.kernel.vger.linux-devicetree |
|---|---|
| Message-ID | <[email protected]> |
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider: - [Low] The AO reset controller node uses a non-generic name 'ao-reset-controller@2000' which fails standard schema validation. -- --- Patch [3]: [PATCH 3/3] arm64: dts: amlogic: a9: Add reset controller support --- commit 0f045fcc683de25785c6ca1a6df4d983c07bc9b4 Author: Xianwei Zhao <[email protected]> arm64: dts: amlogic: a9: Add reset controller support This commit adds reset controller descriptions for the Amlogic A9 SoC. It includes the corresponding reset IDs header and device tree nodes for both the main and ao reset controllers. [ ... ] > diff --git a/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi b/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi > --- a/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi > +++ b/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi [ ... ] > @@ -204,6 +212,12 @@ aobus: bus@ffa00000 { > #size-cells = <2>; > ranges = <0x0 0x0 0x0 0xffa00000 0x0 0x100000>; > > + ao_reset: ao-reset-controller@2000 { [Severity: Low] Could this node use the generic name reset-controller@2000 instead? Standard device tree schema validation expects reset controllers to match the generic pattern ^reset-controller(@.*)?$. Using ao-reset-controller@2000 will likely trigger a validation warning when running make dtbs_check. > + compatible = "amlogic,a9-ao-reset"; > + reg = <0x0 0x2000 0x0 0xc>; > + #reset-cells = <1>; > + }; > + > aobus_pinctrl: pinctrl@4000 { > compatible = "amlogic,pinctrl-a9"; > #address-cells = <2>; -- Sashiko AI review · https://sashiko.dev/#/patchset/[email protected]?part=3 _______________________________________________ linux-amlogic mailing list [email protected] http://lists.infradead.org/mailman/listinfo/linux-amlogic