Re: [PATCH 3/3] arm64: dts: amlogic: a9: Add reset controller support
Xianwei Zhao <[email protected]>
| Newsgroups | org.infradead.lists.linux-amlogic,dev.linux.lists.sashiko-reviews,org.kernel.vger.linux-devicetree |
|---|---|
| Message-ID | <[email protected]> |
On 2026/7/9 16:35, [email protected] wrote: > arm64: dts: amlogic: a9: Add reset controller support > > This commit adds reset controller descriptions for the Amlogic A9 SoC. > It includes the corresponding reset IDs header and device tree nodes for > both the main and ao reset controllers. > > [ ... ] > >> diff --git a/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi b/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi >> --- a/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi >> +++ b/arch/arm64/boot/dts/amlogic/amlogic-a9.dtsi > [ ... ] > >> @@ -204,6 +212,12 @@ aobus: bus@ffa00000 { >> #size-cells = <2>; >> ranges = <0x0 0x0 0x0 0xffa00000 0x0 0x100000>; >> >> + ao_reset: ao-reset-controller@2000 { > [Severity: Low] > Could this node use the generic name reset-controller@2000 instead? Standard > device tree schema validation expects reset controllers to match the generic > pattern ^reset-controller(@.*)?$. Using ao-reset-controller@2000 will likely > trigger a validation warning when running make dtbs_check. > will use node-name reset-controller >> + compatible = "amlogic,a9-ao-reset"; >> + reg = <0x0 0x2000 0x0 0xc>; >> + #reset-cells = <1>; >> + }; >> + >> aobus_pinctrl: pinctrl@4000 { >> compatible = "amlogic,pinctrl-a9"; >> #address-cells = <2>; _______________________________________________ linux-amlogic mailing list [email protected] http://lists.infradead.org/mailman/listinfo/linux-amlogic