Re: [PATCH v5 09/10] phy: rockchip: samsung-hdptx: Simplify GRF access with FIELD_PREP_WM16()
Manivannan Sadhasivam <[email protected]> Fri, 7 Aug 2026 15:11:45 +0200
| Newsgroups | org.infradead.lists.linux-rockchip,org.infradead.lists.linux-arm-kernel,org.infradead.lists.linux-phy,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <yaed2hz7guhtcxf4dpedj36slsmbigsp2funn4jhmum55lh46l@qvicusqkd543> |
On Thu, Jul 23, 2026 at 10:41:52PM +0300, Cristian Ciocaltea wrote: > The 16 most significant bits of the general-purpose register (GRF) are > used as a write-enable mask for the remaining 16 bits. > > Make use of the recently introduced FIELD_PREP_WM16() macro to avoid > open-coding the bit shift operations and improve code readability. > > Tested-by: Thomas Niederprüm <[email protected]> > Tested-by: Simon Wright <[email protected]> > Tested-by: Diederik de Haas <[email protected]> # NanoPC-T6 LTS > Reviewed-by: Dmitry Baryshkov <[email protected]> > Signed-off-by: Cristian Ciocaltea <[email protected]> Reviewed-by: Manivannan Sadhasivam <[email protected]> - Mani -- மணிவண்ணன் சதாசிவம் _______________________________________________ Linux-rockchip mailing list [email protected] http://lists.infradead.org/mailman/listinfo/linux-rockchip