Re: [PATCH v5 10/10] phy: rockchip: samsung-hdptx: Consistently use bitfield macros
Manivannan Sadhasivam <[email protected]> Fri, 7 Aug 2026 15:12:50 +0200
| Newsgroups | org.infradead.lists.linux-rockchip,org.infradead.lists.linux-arm-kernel,org.infradead.lists.linux-phy,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <pemlt3unw2rp6womindyxpdpcw6xnrkn63xkhk26xns6iht42r@lee2spi4j5jo> |
On Thu, Jul 23, 2026 at 10:41:53PM +0300, Cristian Ciocaltea wrote: > Make the code more robust and improve readability by using the available > bitfield macros (e.g. FIELD_PREP, FIELD_GET) whenever possible, instead > of open coding the related bit operations. > > Tested-by: Thomas Niederprüm <[email protected]> > Tested-by: Simon Wright <[email protected]> > Tested-by: Diederik de Haas <[email protected]> # NanoPC-T6 LTS > Reviewed-by: Dmitry Baryshkov <[email protected]> > Signed-off-by: Cristian Ciocaltea <[email protected]> Reviewed-by: Manivannan Sadhasivam <[email protected]> - Mani -- மணிவண்ணன் சதாசிவம் _______________________________________________ Linux-rockchip mailing list [email protected] http://lists.infradead.org/mailman/listinfo/linux-rockchip