[MODERATED] Re: [PATCH 2/2] more sampling fun 2
Konrad Rzeszutek Wilk <[email protected]> Wed, 26 Feb 2020 17:19:25 -0500
| Newsgroups | org.kernel.lore.historical-speck |
|---|---|
| Message-ID | <[email protected]> |
On Wed, Feb 26, 2020 at 10:16:46PM +0100, speck for Thomas Gleixner wrote: > speck for Josh Poimboeuf <[email protected]> writes: > > On Tue, Feb 25, 2020 at 03:59:06PM +0100, speck for Borislav Petkov wrote: > >> > I'd expect to call this one "SRBDS" a year from now. I find > >> > "srb_sampling" to be confusing and hard to remember because it renames > >> > something that already has an industry standard name. > >> > >> srb_sampling *is* srbds - just more readable. > >> > >> We are not giving any new names to the vulns - we're simply making our command > >> line options more readable so that when you have to type them, you either have > >> to remember "srbds" - in that order - or "srb sampling". > >> > >> Latter is easier for me. > > > > But you're leaving out the "data" portion of the acronym/name. > > > > Either call it "srbds" or "special_register_buffer_data_sampling" -- but > > *please* don't give it a new name. It will just create more confusion. > > > > If you can't remember what srbds stands for, that's why we have > > documentation and search engines. > > Our command line options for this mess are inconsistent already, but for > most of them we have actual acronyms used, so lets just go with srbds. Sounds like shruberryds. I wonder if Google will autocorrect 'srbds' to shrubbery or shrubs. > > Having a half correct, but more elaborate one does not really help. If > at all you want to come up with a snarky one like: > > super_random_but_data_stolen = [hell_no, shrug, nsa] Nah, the_knights_of_ni=? :-) How about rng_secure=on,off Since that is all folks will care about. And mitigation=off will tweak it to off too. > > Thanks, > > tglx >