[MODERATED] Re: [PATCH v2 2/2] v2: more sampling fun 2
Borislav Petkov <[email protected]> Wed, 26 Feb 2020 19:13:25 +0100
| Newsgroups | org.kernel.lore.historical-speck |
|---|---|
| Message-ID | <[email protected]> |
On Wed, Feb 26, 2020 at 09:35:08AM -0800, speck for mark gross wrote:
> > This "We" sounds like you mean Intel...?
> yes, this instance of "we" is an intel statement from that white paper I'm
> waiting on for the documentation patch.
See how "we" means different things and how you should avoid it in
commit messages?
IOW, pls use passive voice.
> I wrote it this way initially because at the time I expected there to be more
> dynamic support for managing this mitigation WRT post boot changes to TSX
> availability. The expectation I was later given was to make it a boot
> commandline control only. I kept it this way mostly out of laziness and
> simplification of the number of mitigation states to track.
Drop it then.
> srb_sampling is no more readable to me and doesn't convay what the
> command line is for. But, more readable is always better.
Ok, let's see what better suggestions/preferences the others might have.
> Perhaps changing into a single value, with any '=' like:
> disable_srbs_mitigation or srbds_mitigation_off would be better?
You don't need to have "disable" or "off" in the actual command line
switch's name if you give it the on/off after the "=".
And as I said already, you don't need to have a tautology by putting
"mitigation" in the mitigation option - it is a mitigation.
--
Regards/Gruss,
Boris.
SUSE Software Solutions Germany GmbH, GF: Felix Imendörffer, HRB 36809, AG Nürnberg
--