Re: [PATCH V2] mediatek: rename MT8188 SCP firmware
Matthias Brugger <[email protected]> Wed, 14 Jan 2026 09:10:42 +0100
| Newsgroups | org.kernel.lore.linux-firmware,org.infradead.lists.linux-mediatek |
|---|---|
| Message-ID | <[email protected]> |
On 14/1/26 08:23, Moudy Ho wrote: > The MT8188 device tree (DTS) is configured for dual core SCP, and the > driver by default attempts to load "scp_c0.img" as the core 0 firmware. > To conform with upstream naming conventions, this patch renames the > existing firmware file "scp.img" to "scp_c0.img" to ensure proper firmware > loading for dual core SCP. > > Signed-off-by: Moudy Ho <[email protected]> Reviewed-by: Matthias Brugger <[email protected]> > --- > WHENCE | 3 ++- > mediatek/mt8188/{scp.img => scp_c0.img} | Bin > 2 files changed, 2 insertions(+), 1 deletion(-) > rename mediatek/mt8188/{scp.img => scp_c0.img} (100%) > > diff --git a/WHENCE b/WHENCE > index 4a211c48..fecf42f8 100644 > --- a/WHENCE > +++ b/WHENCE > @@ -6057,7 +6057,8 @@ File: mediatek/mt8192/scp.img > Version: v2.0.20536 > File: mediatek/mt8195/scp.img > Version: v2.0.21961 > -File: mediatek/mt8188/scp.img > +File: mediatek/mt8188/scp_c0.img > +Link: mediatek/mt8188/scp.img -> scp_c0.img > Version: v2.0.27748 > File: mediatek/mt8189/scp.img > Version: v1.0.0 > diff --git a/mediatek/mt8188/scp.img b/mediatek/mt8188/scp_c0.img > similarity index 100% > rename from mediatek/mt8188/scp.img > rename to mediatek/mt8188/scp_c0.img