Re: [PATCH V2] mediatek: rename MT8188 SCP firmware

Dmitry Baryshkov <[email protected]> Wed, 14 Jan 2026 10:27:15 +0200
Newsgroups org.kernel.lore.linux-firmware,org.infradead.lists.linux-mediatek
Message-ID <ybxcmmbn725wwh4gx222lzosyklp32rrc5tzspczqnkyob5wzc@lmvexbvibp6z>
On Wed, Jan 14, 2026 at 03:23:03PM +0800, Moudy Ho wrote:
> The MT8188 device tree (DTS) is configured for dual core SCP, and the
> driver by default attempts to load "scp_c0.img" as the core 0 firmware.
> To conform with upstream naming conventions, this patch renames the
> existing firmware file "scp.img" to "scp_c0.img" to ensure proper firmware
> loading for dual core SCP.
> 
> Signed-off-by: Moudy Ho <[email protected]>
> ---
>  WHENCE                                  |   3 ++-
>  mediatek/mt8188/{scp.img => scp_c0.img} | Bin
>  2 files changed, 2 insertions(+), 1 deletion(-)
>  rename mediatek/mt8188/{scp.img => scp_c0.img} (100%)
> 

Thanks, merged and pushed out: https://gitlab.com/kernel-firmware/linux-firmware/-/merge_requests/865

-- 
With best wishes
Dmitry