Re: qcom: vpu: Add video firmware Gen2 binary for SC7280

Dikshita Agarwal <[email protected]> Thu, 19 Feb 2026 18:02:41 +0530
Newsgroups org.kernel.lore.linux-firmware
Message-ID <[email protected]>

On 2/19/2026 11:46 AM, Dmitry Baryshkov wrote:
> On Thu, Feb 19, 2026 at 11:09:29AM +0530, Dikshita Agarwal wrote:
>> Hi,
>>
>> The following changes since commit f2dbd7a7a74be0d309d8058a55308dcea33a41d6:
>>
>>   Merge branch 'robot/pr-0-1770355730' into 'main' (2026-02-06 07:17:03 +0000)
>>
>> are available in the Git repository at:
>>
>>   https://git.codelinaro.org/clo/linux-kernel/linux-firmware.git
>> video-fw-kodiak-gen2
>>
>> for you to fetch changes up to 3da84f1b4bb062f18d7f08807beeb46328e06d46:
>>
>>   qcom vpu: Add video firmware Gen2 binary for SC7280 (2026-02-19 11:01:56
>> +0530)
>>
>> ----------------------------------------------------------------
>> Dikshita Agarwal (1):
>>       qcom vpu: Add video firmware Gen2 binary for SC7280
>>
>>  WHENCE                        |   4 ++++
>>  qcom/vpu/vpu20_p1_s6_gen2.mbn | Bin 0 -> 2030620 bytes
> 
> What is the difference from the existing qcom/vpu/vpu20_p1_gen2.mbn?
> Why did you use a different name for the binary? Why are we not
> providing the backwards compatibility with the previous name?

As I mentioned in the other thread, the earlier binary I posted was
incorrect. It contained an MBN v7 header, which is not compatible with the
SC7280. The correct binary should use an MBN v6 header.

This one uses the MBN v6 header, which is why it is named
vpu20_p1_s6_gen2.mbn following the same naming convention as other video
firmwares.

I was initially planning to drop the non‑working firmware vpu20_p1_gen2.mbn
in this PR, but since you already raised a PR for it, I didn’t make any
changes regarding that file.

> 
> Granted your comment on the previous binary, was it actually tested?

Yes, it is tested.

Thanks,
Dikshita
> 
> 
>>  2 files changed, 4 insertions(+)
>>  create mode 100644 qcom/vpu/vpu20_p1_s6_gen2.mbn
>>
>> Thanks,
>> Dikshita
>