Re: [PATCH v2] common/rc: support f2fs in _require_fanotify_ioerrors()

Zorro Lang <[email protected]> Tue, 28 Jul 2026 01:50:08 +0800
Newsgroups org.kernel.vger.fstests,net.sourceforge.lists.linux-f2fs-devel
Message-ID <ameWjhJLY41-hWQ4@zlang-mailbox>
On Wed, Jul 22, 2026 at 07:56:33AM +0800, Anand Suveer Jain wrote:
> 
> > Hi Chao and Anand,
> > 
> > The *_fs_sysfs related helpers were brought in by me in:
> >   commit 2a7b77abcd1dde735186b363da24540706c43b73
> >   Author: Zorro Lang <[email protected]>
> >   Date:   Tue Jul 5 17:30:24 2016 +0800
> > 
> >     xfs: configurable behavior on errors at unmount time
> > 
> > At that time, I didn't think about the "features/" directory.
> > 
> > Now, let me rethink this set of helpers. I feel that the *_fs_sysfs
> > family of functions shouldn't be restricted to the $dev directory,
> > we should remove this restriction.
> > 
> > Following that, we bring in *_fs_sysfs_device (appending the _device suffix)
> > helpers which call *_fs_sysfs(). Also change the test cases who call these
> > functions.
> > 
> > Finally, we can introduce the *_fs_sysfs_features functions (or simply use
> > *_fs_sysfs directly).
> > 
> > Also, we have both *_fs_sysfs_attr and *_fs_sysfs, and the logic between
> > them is somewhat confusing and easy to mix up.
> > 
> > I need to write a series of patches to clean up these logic. For this current
> > patch, we can start with a small-scale change first. What do you think?
> > 
> I noticed some duplicate code that needs cleanup.
> Essentially, I think we can maintain two sysfs check helpers:
> one that involves mounting the device, and
> another for module-level feature checks.

How about:

- *_fs_sysfs()
|
+--> *_fs_sysfs_device()
|
`--> *_fs_sysfs_feature()

I also need to clean up and unify _fs_sysfs() and _fs_sysfs_attr() .

Thanks,
Zorro

> 
> Thanks for the help, Zorro.
> 
> Anand