Re: [PATCH 7/7] odb/streaming: unify function names to create new streams
Justin Tobler <[email protected]> Tue, 4 Aug 2026 13:30:06 -0500
| Newsgroups | org.kernel.vger.git |
|---|---|
| Message-ID | <anIu8xOTtZdhDNRD@denethor> |
On 26/08/04 09:25AM, Patrick Steinhardt wrote: > Unify the function names to create new streams from different sources so > that they follow a common schema. While at it, document the ownership of > the file descriptor passed to `odb_stream_from_fd()`. > > Signed-off-by: Patrick Steinhardt <[email protected]> > --- [snip] > +/* > + * Create a new object stream for the given file descriptor. This can be used > + * to, for example, stream an object into the object database. This function > + * does _not_ take ownership of the file descriptor. It's the responsibility of > + * the caller to close it after the stream has been closed. > + */ > +struct odb_stream *odb_stream_from_fd(int fd, size_t size, enum object_type type); Ah ok, here we rename `odb_write_stream_from_fd()` to `odb_stream_from_fd()`. This also addresses one of my comments from a previous patch. The renames in this patch all look sensible to me. Thanks. -Justin