Re: [patch hail] remove duplicated stc_readport

Jeff Garzik <[email protected]> Tue, 26 Oct 2010 17:33:13 -0400
Newsgroups org.kernel.vger.hail-devel
Message-ID <[email protected]>
On 10/26/2010 03:47 PM, Pete Zaitcev wrote:
> Now that we have a common library for Hail, an opportunity opens to trim
> some duplication, such as stc_readport. It even had a comment about it.
>
> Note that we leave cld_readport in the API for a few weeks, while I get
> my tabled trees and RPMs in order. Unfortunately we routinely neglect
> to set specific version in RPM headers (e.g. no Requires: cld>= 0.8.2).
>
> Also, get rid of g_file_get_contents. Talk about pointless: it requires
> caller to free memory, and it's not like code is any more compact or
> easier to understand.
>
> Signed-off-by: Pete Zaitcev<[email protected]>

applied

it would be nice if a follow-up patch moved the hail_readport() 
definition into a more generic, not-CLD-specific header such as 
include/hail.h[1]

	Jeff


[1] which doesn't exist yet.  maybe we could rename hail_log.h to 
hail.h, and make hail.h a dumping ground for hail-generic items.