Re: CONFIG_SMALL_KERNEL option added

MFLD <[email protected]> Mon, 23 Mar 2015 09:16:35 +0100
Newsgroups org.kernel.vger.linux-8086
Message-ID <[email protected]>
Hello Jody,

Reducing the kernel size by making it less verbous looks fine, but I 
think the option is misnamed and that could lead to confusion. A newbie 
like me would understand that option as "reduce the kernel features to 
gain space", not the amount of traces. So I would rename it something 
like "VERBOSE_LESS" ?

Also, could it be possible to make such changes like this latest one in 
another development branch, so that we could have a stable master 
branch, as the official Linux, so that we could review, test, validate 
and mature the changes on our different platforms before merging them ?

Regards,

Marc-F. Lucca-Daniau


Le 23/03/2015 03:21, Jody Bruchon a écrit :
> I've added a new kernel configuration option that reduces the size of 
> the kernel without harmfully changing kernel functionality. 
> CONFIG_SMALL_KERNEL will turn off some unnecessary informational 
> driver initialization messages and the code that is used to generate 
> them. This will be expanded as I find more opportunities in the code 
> to apply it. For now, if you use the current git snapshot with and 
> without this option selected, the results will be something like this:
>
> text    data    bss     dec
> 55840   6984    50884   113708  CONFIG_SMALL_KERNEL=n
> 55152   6720    50884   112756  CONFIG_SMALL_KERNEL=y
>  -688   -264        0     -952  Change
>
> I also updated the kernel defconfig to match currently available 
> options and cleaned out some junk kernel config options that were not 
> referenced anywhere in the actual code.

--
To unsubscribe from this list: send the line "unsubscribe linux-8086" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html