Re: CONFIG_SMALL_KERNEL option added

Jody Bruchon <[email protected]> Mon, 23 Mar 2015 06:43:35 -0400
Newsgroups org.kernel.vger.linux-8086
Message-ID <[email protected]>
On 3/23/2015 4:16 AM, MFLD wrote:
> Reducing the kernel size by making it less verbous looks fine, but I
> think the option is misnamed and that could lead to confusion. A newbie
> like me would understand that option as "reduce the kernel features to
> gain space", not the amount of traces. So I would rename it something
> like "VERBOSE_LESS" ?

The plan is to have the option reduce size in other code as needed, not
just to reduce the number of messages in the kernel.

> Also, could it be possible to make such changes like this latest one in
> another development branch, so that we could have a stable master
> branch, as the official Linux, so that we could review, test, validate
> and mature the changes on our different platforms before merging them ?

ELKS isn't stable enough to justify adding branches for the sake of
having a "stable master" branch. It was only with the release of 0.2.0
that it could be considered remotely close to "stable." Even since then,
I've fixed numerous problems with the code. I'd prefer not to call
anything "stable" until ELKS is at a point that version 1.0 is
justifiable. There are only two people actively working on the ELKS code
base right now, so that's going to take some time.

-Jody