Re: [PATCH 1/2] PCI/P2PDMA: Update DMABUF lifecycle docs after move_notify() rename
Logan Gunthorpe <[email protected]>
| Newsgroups | org.kernel.vger.linux-doc,org.freedesktop.lists.dri-devel,org.kernel.vger.linux-kernel,org.kernel.vger.linux-media,org.kernel.vger.linux-pci |
|---|---|
| Message-ID | <[email protected]> |
On 2026-08-25 00:28, Leon Romanovsky wrote: > From: Leon Romanovsky <[email protected]> > > Commit 95308225e5ba ("dma-buf: Rename dma_buf_move_notify() to > dma_buf_invalidate_mappings()") left the DMABUF section of the P2PDMA > documentation pointing at move_notify(), a symbol that no longer > exists. Readers grepping for it find nothing, and this is the only > place in Documentation/ describing the revocation requirement. > > Name the current function and record that importers which cannot unmap > within bounded time have to be rejected at attach time, which is what > makes the synchronous unmap on remove() achievable. > > Fixes: 95308225e5ba ("dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()") > Signed-off-by: Leon Romanovsky <[email protected]> Reviewed-by: Logan Gunthorpe <[email protected]>