Re: [PATCH] EDAC: fsl_ddr: use devm_platform_ioremap_resource()

Borislav Petkov <[email protected]> Thu, 30 Jul 2026 17:09:14 -0700
Newsgroups org.kernel.vger.linux-edac,dev.linux.lists.imx,dev.linux.lists.llvm,org.kernel.vger.linux-kernel
Message-ID <20260731000914.GJamvnqpHP9L5b8s_h@fat_crate.local>
On Tue, Jul 14, 2026 at 04:46:09PM -0700, Rosen Penev wrote:
> Subject: Re: [PATCH] EDAC: fsl_ddr: use devm_platform_ioremap_resource()

Before you send patches in the future, do:

git log -p drivers/edac/fsl_ddr_edac.c

and look at how things are formatted there. For example, the subject prefix
is:

EDAC/fsl_ddr: ...

and so on.

The EDAC tree uses the same rules as the tip tree, you might want to read them
before sending patches:

https://docs.kernel.org/process/maintainer-tip.html

> Replace the open-coded of_address_to_resource() plus devm_request_mem_region()
> and devm_ioremap() sequence with devm_platform_ioremap_resource(), which folds
> the resource lookup, region reservation and mapping into one step and returns
> an ERR_PTR checked with IS_ERR()/PTR_ERR().
> 
> Behaviorally equivalent with respect to region reservation: the driver
> already reserved the region, so the non-overlapping reg requirement was
> already satisfied. Drop the now-unused linux/of_address.h include.
> 
> Built for arm64 (defconfig + CONFIG_EDAC_FSL_DDR) with LLVM=1;
> drivers/edac/fsl_ddr_edac.o compiles cleanly.

Testing blurb belongs ...

> Assisted-by: opencode:hy3-free
> Signed-off-by: Rosen Penev <[email protected]>
> ---

... here, under the three "---" so that it doesn't land in the commit message.

Thx.

-- 
Regards/Gruss,
    Boris.

https://people.kernel.org/tglx/notes-about-netiquette