Re: [PATCH] staging: sm750fb: rename variables to avoid CamelCase
Greg KH <[email protected]> Tue, 7 Jul 2026 11:11:30 +0200
| Newsgroups | org.kernel.vger.linux-fbdev,dev.linux.lists.linux-staging,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <2026070710-exact-unveiling-e321@gregkh> |
On Tue, Jun 23, 2026 at 07:06:14PM -0300, André Moreira wrote: > Rename 'pvReg' to 'pv_reg' and 'setAllEngOff' to 'set_all_eng_off' > throughout the driver to comply with the Linux kernel coding style. > > Signed-off-by: André Moreira <[email protected]> > --- > drivers/staging/sm750fb/sm750.c | 6 +++--- > drivers/staging/sm750fb/sm750.h | 4 ++-- > drivers/staging/sm750fb/sm750_hw.c | 12 ++++++------ > 3 files changed, 11 insertions(+), 11 deletions(-) > > diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c > index 89c811e0806c4..716a8935f58d1 100644 > --- a/drivers/staging/sm750fb/sm750.c > +++ b/drivers/staging/sm750fb/sm750.c > @@ -743,7 +743,7 @@ static int lynxfb_set_fbinfo(struct fb_info *info, int index) > * must be set after crtc member initialized > */ > crtc->cursor.offset = crtc->o_screen + crtc->vidmem_size - 1024; > - crtc->cursor.mmio = sm750_dev->pvReg + > + crtc->cursor.mmio = sm750_dev->pv_reg + This variable name is still in hungarian notation, which is not allowed in kernel variable names. thanks, greg k-h