Re: [PATCH v5 14/17] elf: Introduce elf64_phdr_size() helper
| Newsgroups | org.kernel.vger.linux-fsdevel,dev.linux.lists.driver-core,dev.linux.lists.loongarch,org.kernel.vger.linux-kernel,org.kvack.linux-mm,org.ozlabs.lists.linuxppc-dev |
|---|---|
| Message-ID | <[email protected]> |
> Add a common helper to compute the total size of an ELF64 header > (Ehdr + program headers) from the number of program headers. > Replace open-coded calculations in powerpc, x86, vmcore, > and crash_core. > > On ppc64, struct elfhdr maps to elf64_hdr, so the powerpc change > is a pure cleanup. > > No functional change intended. > > Cc: Madhavan Srinivasan <[email protected]> > Cc: Michael Ellerman <[email protected]> > Cc: Nicholas Piggin <[email protected]> > Cc: "Christophe Leroy (CS GROUP)" <[email protected]> > Cc: Thomas Gleixner <[email protected]> > Cc: Ingo Molnar <[email protected]> > Cc: Borislav Petkov <[email protected]> > Cc: Dave Hansen <[email protected]> > Cc: "H. Peter Anvin" <[email protected]> > Cc: Andrew Morton <[email protected]> > Cc: Baoquan He <[email protected]> > Cc: Mike Rapoport <[email protected]> > Cc: Pasha Tatashin <[email protected]> > Cc: Pratyush Yadav <[email protected]> > Cc: Dave Young <[email protected]> > Cc: Kees Cook <[email protected]> > Cc: Sourabh Jain <[email protected]> > Signed-off-by: Jinjie Ruan <[email protected]> Sashiko has reviewed this patch and found no issues. It looks great! -- Sashiko AI review · https://sashiko.dev/#/patchset/[email protected]?part=14