Re: [PATCH v3 0/4] arch, mm: consolidate empty_zero_page
[email protected] Thu, 30 Apr 2026 03:25:09 +0000
| Newsgroups | org.kernel.vger.linux-hexagon,dev.linux.lists.loongarch,org.infradead.lists.linux-riscv,org.infradead.lists.linux-snps-arc,org.infradead.lists.linux-um,org.kernel.vger.linux-alpha,org.kernel.vger.linux-csky,org.kernel.vger.linux-kernel,org.kernel.vger.linux-m68k,org.kernel.vger.linux-openrisc,org.kernel.vger.linux-parisc,org.kernel.vger.linux-sh,org.kernel.vger.sparclinux,org.kvack.linux-mm,org.ozlabs.lists.linuxppc-dev |
|---|---|
| Message-ID | <177751950929.2274119.3965174046465654804.git-patchwork-notify@kernel.org> |
Hello: This series was applied to riscv/linux.git (fixes) by Andrew Morton <[email protected]>: On Wed, 11 Feb 2026 12:31:37 +0200 you wrote: > From: "Mike Rapoport (Microsoft)" <[email protected]> > > Hi, > > These patches cleanup handling of ZERO_PAGE() and zero_pfn. > > v3 changes: > * move zero_page_pfn extern declaration back inside the helpers > * add tags, thanks all! > > [...] Here is the summary with links: - [v3,1/4] mm: don't special case !MMU for is_zero_pfn() and my_zero_pfn() https://git.kernel.org/riscv/c/652d12bc74a0 - [v3,2/4] mm: rename my_zero_pfn() to zero_pfn() https://git.kernel.org/riscv/c/9a1d0c738b45 - [v3,3/4] arch, mm: consolidate empty_zero_page https://git.kernel.org/riscv/c/6215d9f4470f - [v3,4/4] mm: cache struct page for empty_zero_page and return it from ZERO_PAGE() https://git.kernel.org/riscv/c/26513781d1b3 You are awesome, thank you! -- Deet-doot-dot, I am a bot. https://korg.docs.kernel.org/patchwork/pwbot.html